TP-Link Bindings No Longer Work After Update From 2.2 to 2.4.0-1

So recently I hooked up my OpenHAB Raspberry Pi I hadn’t been using in about a year and some (I was mainly using it to control TV related tasks via CEC, but the TV died and the replacement I ended up with months later as a stop gap has no CEC abilities, along with other issues, so was no reason to use OpenHAB until I got other hardware again, which I do now).

At first I had an issue where addons were automatically uninstalling themselves and even after restoring from a backup image of the last good build it was still doing it. So I decided to run the updater, but that broke a myriad of other things too. So I just copied all the config files for Items, Rules, Things, and Sitemap and do a fresh install of OpenHABIAN 2.4.0-1 from the latest image and reinstall all the plugins. This seems to work now, but the HS100 switch I had for the TP-Link Binding no longer seems to function. I use this to control a fan in my room. The switch does show in the Paper UI in the inbox, but i’d rather have it setup via the config files. As far as I can tell from the documentation on the site for the binding, nothing has changed in the way it needs to be setup, but whenever I try to control it, nothing happens and Karaf returns with.

17:35:12.491 [INFO ] [.rest.core.internal.item.ItemResource] - Received HTTP POST request at ‘items/Fan’ for the unknown item ‘Fan’.
17:35:15.827 [INFO ] [.rest.core.internal.item.ItemResource] - Received HTTP POST request at ‘items/Fan’ for the unknown item ‘Fan’.

Below are the current lines used in the Things and Items configs.


//TP-Link HS100
Thing tplinksmarthome:hs100:FAN “Fan” [ ipAddress=“XXX.XXX.XXX.XXX”, refresh=60 ]


//TP-Link HS100
Switch FAN “Fan” [ “Switchable” ] { channel=“tplinksmarthome:hs100:FAN:switch” }

Any help would be much appreciated.

The message seems to be pointing to the item. Just to check in your example item you mis the close bracket: }. (This might be just a copy error of you to this topic, but just to check).

Or do you have a typo in the file or filename (seems strange if you copied the files, but just checking)? For example if you edit the items or things file and then save it. Does it show up in the log as being reloaded?

If you add the thing from the inbox. Does the device work?

For some odd reason it WAS missing the }. I fixed this and karaf shows it’s reloaded, but same error when trying to use it.

Edit: Ah. Fixed it. For some reason there was a capitalization error in the sitemap for the item name. Something odd happened for sure since I simply copied the files off the samba share from 2.2 and copied them back for 2.4.0-1.