TP-Link LED control not functioning as expected

New to OpenHab (today) from Home Assistant and trying to mess with my existing TPLink switches.

Reading through the below thread I want to add my TPLink switches as well as disable the LEDs for them as they are in a bedroom.

Followed the instructions from @hilbrand and @rpwong … THANKS to the detailed instructions I was able to add the Beta TPLink Binding from the Eclipse marketplace and add two of my switches.

I have added the Switch LED control for both switches, I believe correctly. However, when I disable the LED it stays on regardless of switch state. Usually the LED ring is only on when the switch is off, however with LED off it’s on either way. Enabling the LED again changes the behavior back to normal (light off, LED on / light on, LED off).

Did I do something wrong or is my understanding of the end goal not correct?


If I understand you correctly.

  • When you switch the led off it stays always on.
  • when you switch the led on it follows the state of the device switch state?

Can you post your thing and item configuration for your TP-Link devices?

Yes, regardless of switch state (off/on) the LED is on.

More or less. Switch state is off, LED is on. Switch state is on, LED is off. This is the default configuration out of the box.

I’m not sure how to post my thing and item configuration. I did it all through the PaperUI and I don’t see anything to get to a textual config. Assumed it would be in the conf folder but there are just readme files. As soon as i figure it out I will post the configs. However, I am beginning to think this may be a TPLink firmware issue.

Can anyone confirm which HS200 their switches are running with this working?

I found a firmware tool that allowed me to rollback from build 171206 to build 171016 but I have the same issue.

Interestingly enough the HS210 (three way switches) and the plugs work as expected. LED is off in the configuration and stays off regardless of switch state.

Changing the thing configuration of the HS200 to an HS210 has no affect on the LED, and looking through the pyHS100 configuration, which is what I am assuming is being used there’s no difference to the command or debug output.

So I’m still thinking some kind of firmware change. Not sure if I have another HS200 in the box to test - so maybe someone else can chime in with their firmware and eliminate that as a possibility.

Hi Brandon,

I haven’t actually updated to Hilbrand’s latest binding, since the original solution has worked fine for me (if it ain’t broke, don’t fix it). I’ll update and test it this weekend.

If you’re like me and hate the ultra-bright LEDs that manufacturers love to put in their devices, you should look into LightDims stickers. I’ve plastered them on all of the annoying LEDs in my house (including my HS200’s before I got into OH).

@rpwong … considering my 210s work without a problem I don’t think you’ll have any issue upgrading. I assume the backend is all using pyHS100 and that appears to be working as well.

The only thing I can come up with is the TPLink firmware itself - so if you could check that at some point and let me know what you’re running that would be sweet. Maybe I can find it somewhere to roll back to. Otherwise I am at a loss. I don’t think it’s my configuration since the 210/100s all work.

I’ve got some electrical tape on it currently that’s “working” but it doesn’t get the rest of the households seal of approval so still looking for a solution.

I tried it out and it works for me. I had to uninstall/reinstall the binding to update to “TP-Link Smart Home Binding (Beta 30-8-2019)”, then delete and rediscover all of my HS200’s in PaperUI to get the Switch LED channel to show up. Once that was done, I was able to control all seven of my HS200’s LED indicators with normal behaviour.

My devices are Hardware Version 2.0 and Firmware Version 1.5.5.

When you toggle your Switch LEDs, what do you see in the log?

Does that apply to all your devices? I’m at work so I can’t verify logs or HW version - but I got to thinking earlier that some of my switches are possibly HW version 1 and perhaps that’s the issue. I’ll be testing that as soon as I get home and then hopefully apologizing for wasting your time! :slight_smile:

Yep, I checked all seven of them.

No apologies necessary…we’re all here to help each other. If the ones that aren’t working are HW Version 1.0, I’d suggest trying the original solution of creating a thing in a .things text file to see if it works. It would look like this:

 tplinksmarthome:hs105:frontdoor "Front Door LED" [ deviceId="8006AA48ACEFC775465946CC3FF53E1019BF0984", refresh=60 ]

You would then create an .items file with:

 Switch LED_Front_Door "LED" {channel="tplinksmarthome:hs105:frontdoor:led"}

This will trick OH into thinking that you have an HS105 outlet, but it will actually send commands to your HS200.

And if that fails, I recommend the LightDims Variety Pack that comes with white stickers to gain your household’s approval. They blend in really well on the HS200 toggle, but you’ll need a couple of them to completely blot out the LED.

It’s all Java, no python. The code for the hs200 and hs105 is the same, so it should not make a difference.

It does look like a firmware bug. I guess they never tested it as the functionality isn’t available in their own app.

Thanks for all your help guys … I did confirm that this is a HW version issue. 1 doesn’t work as expected. 2/3 versions work fine. I’ve tried sending the command through OH and through the Python command line with the same issue on v1. Also tried emulating another plug as @rpwong had suggested and had the same issue. So it’s clearly a HW issue and I doubt there’s anything that can be done in the software to correct.

Thanks again for the help - you guys rock.

Doesn’t sound like like it, but if you do have some HW Version 2’s, then you could at least swap them into the places where they matter most (e.g. bedrooms). Cheers!