TP Smart Plug


Can anyone help with or is it possible to control TP-Link HS100 Smart Plug via OpenHab?

Atm Im using it through Kasa app to control it but would like to also use through OpenHab.

Yes it is possible (in fact I am using it, it works great). You may want to search the forum, there are several threads to this topic. And there is a binding on the marketplace (configure PaperUI to show bindings from the market place and simply install it).

Thanks @lipp_markus I found it but its not working for me… Im a newbie and bit lost so far this what I did

I installed TP-Link Smart Home Device binding
I followed this:
tp-linksmarthome:hs100:home “Living Room” [ ipAddress=“of the smart device”, refresh=60 ]


Switch TP_L_Switch “Switch” { channel=“tp-linksmarthome:hs100:home:switch” }

Then nothing… Not sure where to go from here

Forget this :smile:
On the next post @lipp_markus has it all covered.

You can try to use the PaperUI and autodiscover your items. That can be easier…

If you want to use the textual configuration (I have everything configured textually), here is what I did to make it work. (and in future pls use code fences to get the easy to read formatting (in the top row of the editor you find the icon for code fences):
So, here is my thing definition (.things file)

Thing tplinksmarthome:hs100:8F65C0 "Office Lamp" [ ipAddress="XXX.XXX.XXX.XXX", refresh=60 ]

and here some of the things associated with it:

Switch Office_Lamp "Office Lamp" (gLivingroom, gTPLink) {channel="tplinksmarthome:hs100:8F65C0:switch"}
Number   TP_L_RSSI_Office    "Office Lamp Signal [%d] dB"  <signal> (Status,Network) { channel="tplinksmarthome:hs100:8F65C0:rssi" } 

If you look closely, you will see that I have numbers where your definition says "home"
You will need to retrieve those device specific ID numbers from the Paper UI (maybe there is a way in Kasa too, have not tried that). So here is what you can do:

  • delete your .things file
  • open PaperUI (make sure you have not activated the option of auto-accepting new things and generating items automatically)
  • start discovery if necessary
  • in your inbox you should find your newly discovered TP device.
  • but you will find the device identifying ID number here
  • once you have the number, write your .things file (use the number where you used “home”) and save it
  • if everything worked out OK, OH has now access to your device and you will notice that the new device in PaperUI has disappeared and won’t show if you start discovery again (which makes sense as it is at this point a known device)
    Hope that works.
1 Like

Hello everbody
can someone tell me how I can install TPlink Binding manuell in PaperUI?
I have a QNAP NAS and OPENHAB 2.0. There I can’t find Eclipse Marketplace or TPLink Binding.
If somone has a Link to an easy to understand explanation how this works I would be very happy :grinning:

@Andi1 As far as I know you would need OpenHAB 2.2 (maybe 2.1) to access the marketplace.

Thanks @lipp_markus
So no chance to install the TP-Link Binding or marketplace manuell in Openhab 2.0. Version?

I am not aware of any, but neither am I the expert as seemingly I am using the latest snapshots only

Thanks @lipp_markus for your help

  • I had to manually add the TP device as start discovery could not find it

  • I wrote my items file (with ID number for TP device)

But in my OpenHab app the Switch is not turning device on or off
And in PaperUI in “things” the TP device’s status is OFFLINE-COMMUNICATION_ERROR - (Communication Timed out)

Even though the TP Device wifi is showing up on my mobile and can be connected.
Where did I go wrong?

If autodiscovery doesn’t work something is wrong, because it should work. This may be indication of some other problems. Maybe you’re using a different version of openHAB? Also thing configuration should be without - : tplinksmarthome: It was with the - in older snapshots of the binding, so make sure you have the latest.

I cant find my device id :confused: I already have one HS100 integrated and now i bought a second one, but i cant find the place with the device id anymore… can you give me some hint?

strong text: Ok, found it accidently: If the thing has been created by autodiscovery, it is located in the “Edit” page of the ting. Just for the case somebody is searching for it also :slight_smile: