TPLinkSmartHome Communication_Error


I´m on openhab 2.5.0 and using two TP-Link HS100 Smart Wi-Fi Plugs together with the TPLinkSmartHome-Binding. It worked well for almost 2 years now. For some time now (once, maybe twice a week) I have been observing communication errors:

Wi-Fi Plug 1:

[hingStatusInfoChangedEvent] - 'tplinksmarthome:hs100:FAD594' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): No route to host (Host unreachable)

Somtetimes seconds, sometimes minutes later the thing is back online:

'tplinksmarthome:hs100:FAD594' changed from OFFLINE (COMMUNICATION_ERROR): No route to host (Host unreachable) to ONLINE

Wi-Fi Plug 2:

'tplinksmarthome:hs100:FAF168' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Read timed out

and, later on:

'tplinksmarthome:hs100:FAF168' changed from OFFLINE (COMMUNICATION_ERROR): Read timed out to ONLINE

Wi-Fi Plug 1 always reports “no route to host”, Plug 2 always reports “Read timed out”. Never the other way around.

As I mentioned earlier, it worked well with previous versions of Openhab. But I can’t say if it all started with openhab 2.5 or if something else went wrong in the meantime. Has anyone else experienced this behavior?


I have the same device in my home and best I can remember I have only seen this once or twice in the past 2 years. I recommend stopping OH and cleaning the cache. If that does not work try uninstalling/reinstalling the binding. Lastly you could go into your router and give the switch a static/reserved IP address.

I have 10+ TP-Link Kasa devices, and I’ve found that they regularly go offline briefly and then come back within a second (even before 2.5). I’m inclined to think the issue is with the Kasas keeping their WiFi connection. It never actually hinders my use of them, so I haven’t worried too much about it (but the log spamming does annoy me).

Out of curiousity, do you have a mesh network? I have two mesh nodes, and I’ve been suspecting that the Kasas are jumping back and forth between them.

You´re right. I do have a mesh network, consisting of one router and one node. WiFi-Plug 1 is 1,5 m from the router, WiFi-Plug 2 is only 1 m from the node. The router and node are at a distance of approx. 10 m. According to the log files, the plugs are temporarily switched offline and go online again on the other device. Both WiFi-Plugs have a static IP address. However, I see no way to establish a static connection to the router or node.

I’m pretty sure it wasn’t like that at the beginning. But obviously it’s the plugs. The stupid thing is that sometimes it takes a little longer. I use the switches for light, and now and then the light doesn’t turn on or off because the switch is currently offline. Since it is only a temporary solution anyway, I can live with it.

Thanks a lot!

What kind of mesh system do you have? I have a Netgear Orbi, and I haven’t found a way to have specific devices prioritize specific nodes (which kind of goes against the purpose of mesh).

EDIT: I’m now wondering if my problem is with the Fast Roaming setting on my Orbi. I’m going to turn that off and see if the Kasas stop jumping around.

That is probably the whole point. I have a AVM Fritzbox and I´m pretty sure there is no way to specify a specific device to connect to. In the future I will switch to mikrotik devices. Then, hopefully, the WiFi-Plugs will also be replaced by KNX wall sockets :crossed_fingers: :grinning:.

Turning off “Fast Roaming” seems to have helped. This discussion got me to look a little closer at my mesh (which I haven’t done in awhile) and discover that my satellite node was showing a poor backhaul connection even though it’s no more than 15ft from the router. It also turns out that Netgear doesn’t push firmware to the satellite node I have, so I had to manually install new firmware. That is…not user-friendly.

I’m guessing that a recent update to the main router resulted in the poor backhaul, which may have also led to devices jumping back and forth. So, hopefully the issue will resolve itself now that I’ve fixed that and turned off Fast Roaming.