[Tradfri] Commands don't change lightbulb [SOLVED]

Hi,

I am trying to control my Tradfri lightbulbs with my freshly installed openHABian image. To connection through the binding seems to work but the bulb just doesn’t change its color/intensity.

What I did:

  • Install a fresh openHABian image (v1.6.2) automatically
  • Install Tradfri binding 3.0.0
  • Import gateway and enter security code (status -> ONLINE)
  • Import bulb (automatic ID | status -> ONLINE)
  • Link color/color_temperature channel to a newly created item

When I change for example the color settings of a bulb the log (frontail) shows following entries:


but the color doesn’t change. Same color temperatur etc. When I change the color through the IKEA app the same entry shows and the color changes. Just not through openHAB.

What I tried:

  • Deleting and newly inserting bulbs and/or gateway
  • Renaming blubs in the IKEA App, deleting the item and insert again (according to this post)
  • Reinstalling the binding
  • Rebooting the raspberry pi

My IKEA gateway and lightbulbs are up to date (gw: 1.12.34 | bulbs: 1.3.013)
openHAB 3.0.0 on a Raspberry Pi 4 4GB

Gateway:

UID: tradfri:gateway:gwd44da439bd55
label: TRÅDFRI Gateway
thingTypeUID: tradfri:gateway
configuration:
host: 192.168.0.110
preSharedKey: 1EAUx2UNFedL1Qmw
port: 5684
identity: e06a6c6acd3442b28ef516bd304a5b73

Bulb:

UID: tradfri:0210:gwd44da439bd55:65539
label: Schlafzimmer
thingTypeUID: tradfri:0210
configuration:
id: 65539
bridgeUID: tradfri:gateway:gwd44da439bd55

I have made all the settings via the UI. Does anyone have/had a similar problem and knows what to do here?

Edit:
After a gateway reset it worked…

1 Like

i had the same issue.
a simple gateway reboot fixed it for me.

1 Like