Tradfri gateway going offline every few days

I have about 30 Ikea Tradfri devices in my house that have been very reliable up until now. But recently (probably about two weeks or so) Openhab has issues connecting to the Tradfri Gateway. I am not sure if this happened with my Openhab upgrade or not - I was using one of the 2.5 Milestone builds and then around the beginning of January updated to the stable release. On thursday I upgraded Openhab again to the latest stable version in the hopes that the problem will go away - it didn’t.

Basically the binding looses connection to the gateway and doesn’t reconnect. I can still connect to the Gateway using the Ikea app just fine. But to reconnect openhab I either have to disable and then re-enable the gateway thing in paper UI, reboot the gateway or reboot the Openhab. All will fix the problem and the thing will then continue working fine for a few days. Until it happens again for some reason.

Does anyone else have similar issues?

1 Like

I did have issues. I found that moving to a things file along with a full reset and re-pair helped. No issues since doing that. I couldn’t tell you which fixed it though.

I have 35 devices total.

I am having similar issues since recently. I am already using a things file, but did not try a re-pair yet, as @chriscolden suggested.

Good to know that I am not the only one.

Same thing here. I am using things file anyways, but I haven’t tried re-pairing.

@chriscolden … by reset and re-pair you mean actually resetting the gateway and re-pairing it with all of the devices or do you mean removing it from Openhab and then re-adding it?

IKEA released a new version ( - maybe this will already do.
By the way, a relative only uses Tradfri together with Alexa and no OpenHAB. He experienced issues in the last days, too.

factory reset. Mine did it randomly and removed all the devices, so I had to do it, not through choice, but either the things file or the fact that i had to repair at the same time seemed to make things more stable. Try things first, before doing to the reset on the gateway.

mine did the reset on the previous firmware. I’ve had no issues with the latest. I think they screwed something up in the firmware which has now been fixed, but left some internal crap on the gateway, which resetting has fixed.

1 Like

I have the same problem, I’m running on OH 2.5.1 and my GW FW version 1.10.29. I’m not running on things file, I’ve used auto-discovery.

There are many threads on Tradfri problems, I’ve written in this thread a while ago.

Detatching and attaching the network cable for the IKEA GW to my ASUS router makes the binding reconnect successfully again. This could indicate that the problem is in the IKEA GW or the binding for some reason hangs the GW communication and that hang is resolved by detach/attatching the NW cable.

I think the problem is in the binding somewhere. Seeing that disabling and then re-enabling the gateway item in the paper ui works. Also since there seem to be no issues with the official app. Maybe Ikea changed something in their FW that is causing issues with the binding.

@roli this issue has been on going for some for many months since a firmware change.

I have configured my tradfri in paper ui and since doing that had no issue on the latest openHAB version.

I do agree with you that there could be a conflict somewhere between tradfri binding and some other thing as only some people have this issue.

I had this issue, which has now cleared since either switching to things file, or the fact the gateway reset itself.

I would move to a things file. Even if you just create a thing for the bridge and add it along side your autodiscovered thing. This way if your auto thing goes offline but your thing file thing is still connected then there is your answer.

1 Like

I’ll try moving to a things file, I’ll keep you updated!

When I came home, the bridge is offline and the log contains:

2020-02-03 18:53:16.417 [DEBUG] [al.discovery.TradfriDiscoveryService] - Adding device tradfri:0210:gwdcefcaba3a07:65541 to inbox
2020-02-03 18:54:16.088 [DEBUG] [g.tradfri.internal.TradfriCoapClient] - CoAP GET request
uri: coaps://
2020-02-03 18:54:16.091 [DEBUG] [.tradfri.internal.TradfriCoapHandler] - CoAP onError
2020-02-03 18:54:16.093 [DEBUG] [.tradfri.internal.TradfriCoapHandler] - CoAP onError
2020-02-03 18:54:16.095 [DEBUG] [ternal.handler.TradfriGatewayHandler] - Gateway communication error. Forcing session resume on next command.
2020-02-03 18:55:16.091 [DEBUG] [g.tradfri.internal.TradfriCoapClient] - CoAP GET request
uri: coaps://
2020-02-03 18:55:16.095 [DEBUG] [.tradfri.internal.TradfriCoapHandler] - CoAP onError
2020-02-03 18:55:16.099 [DEBUG] [.tradfri.internal.TradfriCoapHandler] - CoAP onError
2020-02-03 18:55:16.100 [DEBUG] [ternal.handler.TradfriGatewayHandler] - Gateway communication error. Forcing session resume on next command.
2020-02-03 18:56:16.102 [DEBUG] [g.tradfri.internal.TradfriCoapClient] - CoAP GET request

I will now configure a things file and keep my fingers crossed :slight_smile:

And I have just tried removing the gateway thing and re-adding it, to see if this will change anything. Because it’s starting to drive everyone around the house insane. Especially when you can’t turn on the light at 5 in the morning because of a stupid bug and you have to use your phone to do it.

Hi. Facing the very same situation here. My tradfri getaway gets offlined in Openhab on a regular basis, while still able to manage through home assistant or google home. Of course, any depending device was also getting offlined. Each time it happened, I had to provide the key again in thing configuration, then it went back online. Then, based on Roli’s post, I noticed that just disabling and re-enabling the gateway thing is sufficient to get everything back online. I’m using the latest version of tradfri FW, with 12 devices connected, and openhab 2.5.1-2.
Quite strange behavior.
It would be great to have a solution from Ikea, and not workarounds to revive the gateway when noticing it gets offline.
Currently evaluating moving to any other reliable documented gateway… Ikea’s smart stuff doesn’t seem so smart …

Well I tried the thing that I mentioned above… I deleted the gateway item from openhab (just the gateway, I left the rest alone) and then re-discovered it. It’s now been 8 days since I tried that, and I don’t seem to have any issues anymore.

I. Implented a workaround. Added crontab entry that restarts the openhab service 3am every night. It has been running smoothly for one week now

So after updating the Openhab to 2.5.2 last week, the above problem with Tradfri is back. And this time removing the gateway and adding it again didn’t solve the issue. :frowning_face:

When openhab eventlog report this:
[hingStatusInfoChangedEvent] - ‘tradfri:gateway:gwa0c9a0d8a641’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR)

openhab never recover and the IKEA GW is never reachable again from openhab until I do full restart of openhab with:
systemctl stop openhab2
systemctl start openhab2

Just to verify that the problem is in Openhab I have installed HomeAssistant to run in parallell.
I run two instances of HomeAssistant. One on a raspberry 3 with Hassio and one instance on the same raspberry pi 4 that run Openhab2. They have never reported any problem to communicate with IKEA GW. And they always can control all my lights and outlets when openahab lost its communication.

The IKEA app also always works without problem.

This has now happened at least 5 times during 4 weeks.

Openhab version 2.5.2 (Build)
Home Assistant 0.105.5 on Raspberry 3 (hassio)
Home Assistant 0.106.2 on Raspberry 4 (python venv)
IKEA GW 1.10.29

1 Like

I have same problems… most of the time it runs for a few days… but lately it is less then a day