TransformationService of type 'SCALE' is unavailable


I use a file UvIndex.scale in my sitemap:

Text item=UvIndex
  label="UV-Index [SCALE(UvIndex.scale):%d]"

However, it isn’t working anymore, get this error:

couldn't transform value in label because transformationService of type 'SCALE' is unavailable

When looking for it, OH2 reports it installed and started.

openhab> feature:list |grep transformation-scale
openhab-transformation-scale                │ 2.4.0.SNAPSHOT   │ x        │ Started     │ openhab-addons-2.4.0-SNAPSHOT │ Scale Transformation

What to do next?

Using 2.4.0~20180701105417-1 on Debian9 with manually installed openHABian.


This shouldn’t be the reason, but try to apply the transformation in your *.items file entry
I haven’t used xforms in sitemaps. Not sure if they work there (I see no reason why not)

Putting it to the .items file makes no difference (I was always using it in sitemaps only and it worked).

then you have all the elements to open up an issue on github :slight_smile:

by the way, sometimes I get the same for the MAP xformation
A simple restart of the OH2 service (after the first startup following an upgrade) solves this one.

Service restart is the first I try when something unusually happens and I’m running beta :smiley:
But unfortunately, the error persists…

same to me, just upgraded openhab and now SCALE doesn`t work anymore.
I´m on openHAB 2.4.0~20180626235718-1 (Build #1304)

Yes I have same problem, scale transformation doesn’t work anymore
I have been tied up with other things before realising that.
@maintainers, is that eclipse or OH to report to?

@vzorglub: GitHub search will lead you to ESH (and btw, for core functionality it’s nearly always ESH) :slight_smile:

Edit: There was a bigger refactoring on the transformation service 5 days ago (PR #5697). Maybe it’s caused by this one. So when you ping triller-telekom in your issue, you might get help a bit faster :wink:

Hey, I opened #5842 at Eclipse SmartHome issue tracker.



Thanks a lot :green_heart: I was too busy to do so.

Sorry, abstract classes in combination with OSGi services are evil…

I have fixed it in

Should be available once a new ESH stable ( is built and openHAB has picked it up afterwards.