Trouble connecting to rpi after upgrading to oh3

hello all,
i have openhabian installed on a rpi3 and after migrating to oh3 i cannot access the rpi.
right now its connected via a lan cable. i can access it tho via putty and i can enter the configuration via openhabian-config. i also canceled the wireless connection in the wireless section couse was saying that your system has a WiFi interface that fails to initialize on installation…
if i enter the system settings and try to activate the wifi it say:

There was an error or interruption during the execution of:
"30 | System Settings"       
Please try again. If the error persists, please read                         │
/opt/openhabian/docs/ or                                  │ how to proceed.

these are my settings in etc/network/interfaces

source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet static

and in etc/dhcpcd.conf

interface eth0

can someone please help me? i just want a fuctional cable connection because i tried the WiFi connection too but its not working properly.
thanks for any hint.

could anyone please share their etc/dhcpcd.conf and etc/network/interfaces. i need to know how the original folders look like. i made many changes in there and right now i cant even access the server via putty. thanks

You may not be using a static IP this way and you must not be messing with config files at all.

Install again from scratch, mind the prerequisites and go read the DEBUG guide if that still does not work.

3 months passed and all my systems are down. i formatted the micro sd card and installed oh3.
i see all my devices on the openhab page and i can make items or links but i cant connect to vscode to use the unbelievable tool called create items from things! i followed a few tutorials, uninstalled and reinstalled vlcode but it cant discover my things on the network!
please anyone point me a way to make openhab work with vsc. i mention that previously with oh2 that was the way i made all my configuration but in oh3 it just wont work.
so i can see everything in openhab interface but i cant make a link with vscode.
please point me a way to start. thanks.

Do you have openHAB vscode plugin installed and configured?

If not then I would start with it.

hello all
guys please help, still couldn’t resolve the problem!
because i couldn’t connect vs code with openhab i formatted the sd card and installed the latest version from github here using balena etcher. before that i tried using the official Raspberry Pi Imager and after that i formatted the sd and tried the second method.
before that, i made the necessary configuration in my router witch is an AX1500 Wi-Fi 6 Router so i made an ip reservation acording to my raspberry pi mac address on the dhcp server tab.
i can access openhabian via putty and FileZilla but i can’t access it with google chrome using the ip:8080 nor the openhabian:8080. it says that this site cant be accessed.
Rasperry pi its connected via cable on my router and im trying to connect with it with my laptop which is connected wireless to the router.
i also can see the raspberry on the network using the advanced ip scanner software.
another thing that happens is that if i go throgh putty in the configuration tab using openhabian-config, i can enter the menu, i can navigate through it but if i want to change the time zone eg it says

There was an error or interruption during the execution of:                  │
│   "30 | System Settings"                                                     │
│                                                                              │
│ Please try again. If the error persists, please read                         │
│ /opt/openhabian/docs/ or                                  │
│ how │
│ to proceed.

please anyone help, thanks!

I am not an expert but it looks like your openhab instance is not running.
You can check it with:

systemctl status openhab.service

thanks for the advice.
if i run this command through putty it says:

openhabian@openhabian:~ $ systemctl status openhab.service
Unit openhab.service could not be found.

if i ping the rpi ip address from my laptop i get the right anser ttl=64
whats going on?

It means that you are not running openhab instance on your RPi.
Pinging IP address is a different story. It only mens that your network interface is responding and is visible in local network. It has nothing to do with openhab.

Please take a look at the documentation:

I don’t understand anymore. I followed the tutorial in the link step nu step, tried to write openHABian on the sd card using the official raspberry pi imager, nothing, than downloading the image card file with etcher. I plugged the internet cable into raspberry and I turned on and leave it for hours as it says on the openHAB page! The dhcp server was configured with the raspberry pi MAC address before turning on the raspberry pi!
Watched a few guys on YouTube installing openHABian without any issue but on my case
I have nothing connected to raspberry, mouse or keyboard as it say.
On the openHAB guide it say that you have to let it do all the installation between 15-45min and you can watch it while installing at openHABian:8080 or by the ip:8080
it just simply doesn’t want to work!
Do anyone meet this situation before?
Any tip would be helpful, thanks.

i dont know if i need to open a new topic but ill still post here.
after 10 times formatic the sd card and installing openhabian via different methods i finally got it runnig.
now because the journey cant be straight like everyones on youtube or other blogs, ofc i cant mapp raspberry on windows 10!
i tried many times using different methods again to connect vsc with openhab but its impossible. i than thought to check the ip on openhabian using hostname -i and it returs this ip but all my ips start with 192.168..... whats goin on? everyone says to let openhabian do his job and to not modify anything in the settings!! whats with this ip? do i need to change it accordingly? i didnt modify anything yet in the openhabian settings!
thanks for your time. is what is called a loopback, it is the computer’s way of saying send this to myself basically, most operating systems use this (for IPv4 traffic)

The manual page of hostname says:

  -i, --ip-address
          Display the network address(es) of the host name. Note that this works only if the host name can be resolved. Avoid using this  op‐
          tion; use hostname --all-ip-addresses instead.
me@pi:~# hostname -i
me@pi:~# hostname -I

In case you have multiple interface ( physical or virtual ) the output may look like:

me@quark:~# hostname -I