Trouble getting Astro Data to work in the Demo file

I am using OH2 and saw the ‘Demo’ file(s) as a good start for my needs. Sadly though I cannot get the Astro data to work fully. The Sun data works a bit, the moon data does not.
My itemfile looks like this, basically the standard demo file

I made the astro data as a thing and I can see I am pulling the data in my PaperUI:

But I encounter the following problems:

  • With regard to the sun, I get the Azimuth, the sunrise and the sunset in my application, but NOT the Elevation
  • Instead of Sunset and Sunrise as defined in my demo file, it says “Start time” and “Start time”
  • I do not get any of the moon data in my application

    oddly though it puts the text “name” behind 'Moonphase"

I realize that my item file binds the moon data with: { channel = “astro:moon:home:phase#name” }, whereas my moonbinding says { channel = “astro:moon:local:phase#name” }, but when I change ‘home’ into ‘local’, it has the same effect of not working.

Slight update:
I removed ‘local moon’ and readdded “Astromoon” (do not know the difference. After retrying and retrying the link suddenly the Moon elevation shows up, but for the life of my i cant see what I did different for the Azimuth and moonphase

What am I doing wrong?

Channel names need to match:

in your items files you have astro:moon:home, in your GUI config you have astro:moon:860f4a79.

If you are a beginner I suggest either do a GUI config OR a textual config, don’t mix them.

Thanks but I have tried both: 860f4a79 as well as home

I’d be happy to do only one, but when I tried Gui I had no idea on where to place my items but I need the paper gui for my bindings and stuff.

Anyway, even when I copy the channel from the GUI, it still isnt working.
My Azimuth is quite happy with ‘home’, so why isnt the ‘Elevation’? It is the same channel.

Nevertheless, you got me thinking, So I set up my own Astro things file in a text editor and I got a bit further. I now have sun elevation, so the sun is complete, and I also Moon Azimuth, but Moonphase still lacking.

Oh well, I will keep trying. Thanks