Trouble in different places

I am extremely new to the OpenHAB community and I am keen to learn more. I have just a couple of questions:

  1. Is there somewhere that has extensive step by step guides for bindings/ssh/items/things etc? I am having trouble understanding how bindings work with things and items, and why my HABPanel widgets don’t always work.

  2. I have been unable to get my uuid and secret codes for for Google Assistant integration. Every time I try to access using /var/lib/openhab2/uuid or /var/lib/openhab2/openhabcloud/secret, i get a “permission denied” error. Nothing I do seems to make it work. I have tried chown, tried chmod with no luck.

  3. I am having trouble understanding how to “move” files for HABPanel templates and widgets. For some widgets I have looked at, it has mentioned having to move icon files for the widget to display properly. I am assuming this has to do with Samba, yet I can’t figure out how to configure Samba share drives to my Windows computer. Am I wrong in thinking these problems are linked?

I am sure I will have more questions, but these are the 3 that have had me stumped for the last few days.

Thanks in advance for any help given, and apologies if these seem like stupid questions.

I think you might already seen this but here are the Docs…

I answered the “What is thing what is item” question already and hope this can help you, if not this Community has more then approx 100 posts just about things and items and helping explaining this

So you are on Linux? Reads like you need some more basic Linux training :wink:
Who owns this file? Normally the user openhab, you can switch to that user via. sudo su openhab and then you can access all the files owned by openHAB

Sounds like the Start of a journey :slight_smile: Most people enjoy and hate it at the same time :blush:

oh… and ps: Read this :wink:

@BrutalBirdie has already most of it:


You are trying to run before you can walk.
Have you followed ALL the tutorials?

Each binding has dedicated documentation.


Before trying to download custom widget get the basics running

1 Like