Trouble setting up WireGuard

  • Platform information:
    • Hardware: Raspberry Pi 4 Model B Rev 1.4
    • OS: Openhabian 1.6.5
    • Java Runtime Environment: openjdk 11.0.12
    • openHAB version: 3.1.0

Dependency problem during Wireguard Installation

Hello everyone,

I’ve done a clean install of openhabian on my Raspberry Pi and I had the idea of setting up a VPN solution and I like Wireguard enough to use it.
Only when installing the packages after entering my network interface, the three bytes of my internal network and my dns I have a dependency problem with bind9 :

2021-09-02_16:08:57_CEST [openHABian] Installing Wireguard required packages (dnsutils)... + install_dnsutils
+ apt-cache show bind9-dnsutils
+ apt-get install --yes bind9-dnsutils
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 bind9-dnsutils : Depends: bind9-libs (= 1:9.16.15-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
+ return 100
+ echo FAILED

I checked my packages, sources etc but I can’t fix the problem, impossible to install these dependencies manually.
Has this case already happened to you?

I’m a beginner in openhab, don’t blame me too much if some things seem absurd to you, I’m here to learn and I tried to look everywhere already if another case existed…

Thanks for your answers !

What is your openHABian version ? (title bar of openhabian-config)

That’s a tricky one and unrelated to openHAB(ian), in fact we cannot resolve debian dependencies.

Try editing /opt/openhabian/functions/helpers.bash around line 482 and change/comment out so it’ll install dnsutils instead of bind9-dnsutils package, then reinstall wireguard.

1 Like

Many thanks for your answer I commented the bind9 part and it worked like a charm.

Here’s the version :

openHABian Configuration Tool — [main]{2021-08-28T12:47:26+02:00}(a7f9438) openHAB 3.1.0 - Release Build