Trouble with DSC binding when panel disconnected


I’ve recently had som problems with my DSC alarm system (,38363.0.html) and have had to power it down between fault searching. But when I do it has the OH2 setup behaving very strange. The log is first of all being flooded with “openConnection(): Socket Exception: No route to host (Host unreachable)” and none of the z-wave devices respond to commands. The z-wave controller reports “frame rejected” to everything.
I suspect that this can be resolved if the binding stops (or at least add some time between the attempts) to reconnect with the panel. I would like to have the bindning try to reconnect every 5 minutes instead of every 5 seconds.
Is there anything i can do about this?

what binding are you using. If your binding uses the TCP binding for any reason, then yes the TCP Binding is broken

Sorry forgot to mention that: binding-dscalarm - 2.4.0 and EnvisaLink 4.
Yes via TCP, are there any other way?

take a look at how we implemented tcp on alarmdecoder binding. Thats what i use for my Vista20P alarm and no hiccups whatsover, even when tcp gets disconnected. You could also bridge the TCP with a small python script so the tcp goes through the Python and not the tcp binding

Ok, I will look on this :slight_smile:
But it sound complicated, and the DSC binding does work perfectly with this minor flaw.

Hello @rockit4,

The DSC binding, in particular the Envisalink bridge, has a configuration parameter that sets the TCP socket connection timeout, which can be changed in the PaperUI. The default setting is 5000 milliseconds (5 seconds). You might try playing with that to see if you get a different result. Maybe set it to zero (infinite) first and then go from there.


I already tried to set it to 10000 (10 sec) but it still updated every 5 sec.
I’ve now set it to 0 to see if it helps. Is 0 disabled? So that if it misses a beat it doesn’t reconnect?
That doesn’t sound so good.
Thanks 4 your help

I believe setting it to zero causes the time out to fall over to the system default, and that would depend on the OS you’re running. But it appears to be having no affect because you are getting an exception before it times out anyway. The bridge is not communicating with the panel because it can’t find the IP address, so it keeps trying. Not sure what to tell you at this point except to stop the binding from running. This might help with that: Bundle Management.

The OH team has added “disable thing” in the Paper UI. So I got it working for now.
But its not so good to come home to a dark house because of this minor detail…
But thanks anyway :slight_smile: