Troubleshooting CalDav Personal - Public Garbage Collection Calendar

Yes, my installation is running OH 2. The documentation for the CalDav stuff is indeed bad and maybe over the holidays I’ll take some time and submit a PR to help clean them up…but if you follow what I did above you should hopefully see some success as mine are continuing to run and pull content from Google calendar into my HabPanel display. Make sure you pay attention when to preappend the caldavio to your content and what cfg file it belongs in. If you have any questions post them here and I’ll do my best to provide whatever guidance I can. It’s been awhile so it may take a bit for me to get the brain back up to speed on this component.


1 Like


Thanks, I greatly appreciate your offer and get back to you soon.
I am using an icloud, but think that this shouldn’t make abig difference.
I will post my config here for you to review,

I am running openhabian and OH 2.5 M4.
Doing the steps mentioned here (actually 3 times):

I was able to find the correct URL (I think)

What I did beside this:
Install caDav Personal binding (I just want to read events and dispay them on a tablet in a family calendar)
Modify caldavio.cfg to:


My caldavPersonal.cfg just contains

I also tried:

Currently I don’t get error messages, but two days ago I got:

2019-11-12 18:33:42.051 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - Querying events for filter: CalDavQuery [calendarIds=[iCloud], from=2019-11-12T18:33:42.037+01:00, to=null, sort=ASCENDING, filterName=null]
2019-11-12 18:33:42.060 [DEBUG] [.io.caldav.internal.CalDavLoaderImpl] - calendar id iCloud not found
2019-11-12 18:33:42.066 [DEBUG] [.io.caldav.internal.CalDavLoaderImpl] - return event list for CalDavQuery [calendarIds=[iCloud], from=2019-11-12T18:33:42.037+01:00, to=null, sort=ASCENDING, filterName=null] with 0 entries

By the way:
What about the caldavio entry:

I removed this because I did not see this in the recommended settings.

According to documentation it is:

  • disableCertificateVerification can just be set to true (default is false) if ssl is used.

SSL = Secure Sockets Layer , SSL is used, when an URL begins with https://

What is the case in your example above.

Thanks - I changed this accordingly.
After reload it looks ok, but I still get a warning:

2019-11-14 15:59:57.874 [DEBUG] [.io.caldav.internal.CalDavLoaderImpl] - Update was called for CalDAV IO.
2019-11-14 15:59:57.882 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: iCloud:disableCertificateVerification
2019-11-14 15:59:57.929 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: iCloud:password
2019-11-14 15:59:57.933 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: iCloud:preloadTime
2019-11-14 15:59:57.936 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: iCloud:reloadInterval
2019-11-14 15:59:57.939 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: iCloud:url
2019-11-14 15:59:57.942 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: iCloud:username
2019-11-14 15:59:57.945 [TRACE] [.io.caldav.internal.CalDavLoaderImpl] - processing configuration parameter: usedCalendars
2019-11-14 15:59:57.950 [WARN ] [.io.caldav.internal.CalDavLoaderImpl] - Unable to parse configuration parameter: usedCalendars

After changing caldavio.cfg and/or caldavPersonal.cfg you have to delete the following:

caldavio.config and caldavPersonal.config in folder

  • /userdata/config/org/openhab/
  • (or: /var/lib/openhab2/config/org/openhab/ )

Then restart openhab. They will be recreated.

But you can also check both .config files, if the entries are correct.

I remember these files, but did not check Them recently.

It works!

Thank you very much @Celaeno1 & @KidSquid

1 Like