Trying again to get thermostat working (solved)

Tags: #<Tag:0x00007fc8ef9822a8> #<Tag:0x00007fc8ef9821e0>

Ok, my thermostat just keeps giving me issues with GA. Always works fine with paperui or habmin. First I already had to split it to appear like two thermostats to GA since GA can’t seem to understand separate setpoints for heating and cooling. In the past it has randomly decided to just not report anything to GA and I have had to work on the item file to fix it (may have been related to the changes the GA integration has been going thru). Last time I asked for help we got it working with the issue that it would first show as “other” mode when I pulled it up in the home app and I had to “switch” it to the mode it was actually in the make any changes.

Now it won’t let me switch.
I’m at the end of my rope with this and am looking for either an answer or a way to set up a usable habpanel item to control the thermostat.

RCS zwave thermostat model TBZ48A (rebranded GoControl TBZ48)

current items file:

https://drive.google.com/file/d/1mtvjXliULi-GJdiz-B14NNYiQNMnm0N5/view?usp=sharing

Any Ideas?

Edit:
After a month and a half of testing in multiple situations (and dealing with a hurricane and other issues) I can say that mapping the GA functions to the numbers in the documentation has fixed the mode issue and lets me use my thermostat (as two separate for heating and cooling) in Google home app and via voice. Thanks to @Bruce_Osborne for the link to the docs!

1 Like

The first thing I spot is that you have a Number item for the mode but do not map modes to numbers.
Thus, the integration tries to convert a number to a string and vice versa which ofc does not work.

You would need something like modes="heat=1,heatcool=2,off=3,cool=4" (no idea what your mode numbers are…)

For separate low and high set points you can use:

  • Number. { ga="thermostatTemperatureSetpointHigh" }
  • Number. { ga="thermostatTemperatureSetpointLow" }
1 Like

With string in there it has in the past not worked at all. But I’ll try again. I assume that setpoint high should be the highest I want it to go (the cooling temperature) and setpoint low to be the opposite? I will report back if it changes anything.

I would try mapping to numbers but while it defaults to number for type I cannot actually find the numbers that the modes map to as openhab just shows mode types whether I have string or number.

I think this is your device and the documentation from the community supported database is pretty thorough. It lists the numerical values and meanings for mode, for instance.

https://www.openhab.org/addons/bindings/zwave/thing.html?manufacturer=linear&file=gctbz48_0_0.html

1 Like

Mapping the numbers to the mode seems to help. (Will take more time and testing to confirm)

Now to try and fix the setpoint issue so I can have it show as one thermostat instead of two.