Trying to add Aeotec WallMote Quad

that seemed to do it! Thank you!

Actually, I’m still having problems with this. The WallModeQuad is showing up in Things now, but I don’t seem to be getting any input from it. Looking at the Thing Properties, I see this:

    zwave_class_basic     BASIC_TYPE_ROUTING_SLAVE
    zwave_class_generic     GENERIC_TYPE_WALL_CONTROLLER
    zwave_frequent     false
    zwave_lastwakeup     2022-01-09T20:19:48Z
   modelId    ZW130
   zwave_listening     false
   zwave_version     2.3
   manufacturerId    0086
    manufacturerRef    0002:0082,0102:0082,0202:0082
    dbReference    535
    zwave_deviceid    130
    zwave_nodeid    7
    vendor    AEON Labs
    defaultAssociations    1
    zwave_routing    true
    zwave_beaming    true
    zwave_secure    false
    zwave_class_specific    SPECIFIC_TYPE_BASIC_WALL_CONTROLLER
    zwave_devicetype    258
    zwave_manufacturer    134

Just to test the connection, I go to update the Test Sound property (switching it between 1 and 0), then I hit save. “Pending” appears next to it. The log says:
ConfigStatusInfo [configStatusMessages=[ConfigStatusMessage [parameterName=config_1_1, type=PENDING, messageKey=null, arguments=null, message=null, statusCode=null], ConfigStatusMessage [parameterName=config_5_4, type=PENDING, messageKey=null, arguments=null, message=null, statusCode=null]]]

Any ideas?


Repeat several times (until ‘Pending’ disappears).

That seems to have fixed the “Pending” issue, but I can only connect with the QuadMote when it is near the Controller. If i bring it into another room (which has some relays in it, and other devices that work fine), it doesn’t update. I have pushed the action button and put it in wake up mode, but it never resolves the “pending” status, seemingly because it isn’t connecting through the network.

For a newly added device. I usually execute a “heal Device” to fill-in the routing tables after I get it fully initialized (quick test is having five lines on the UI page for the device). Heal won’t work without five lines showing. For a battery device press the action button after setting the “HEAL”. It’s not done until you have 5 lines again
Five Lines of configured node

Theoretically the controller should find a route when you move the device around, but having the tables populated gives it a better chance.


Thanks, Bob. Even if I have the QuadMote next to the controller and I put it in wake up mode a few times, I can’t get 5 lines. I’ve tried to heal it regardless, but nothing changes.

And now when I update a configuration parameter and hit save, the parameter immediately reverts back to the value it was at before I changed it. “Pending” doesn’t appear anymore.

Ok let me back up to the beginning.
The device should have been paired while the Zstick was connected to a running OH and the inbox was in scan mode (Plus sign–>Zwave binding —> Scan (while following the device “inclusion” protocol)) Is that what you did?

Next is the device initialization. The more detailed test beside 5 lines -
Is there an .xml file with the node number 7 in the userdata/zwave folder?
If no- it is not initialized.

If yes,

  1. Is the time stamp after the time stamp for the controller node?
    There are three main reasons why the 5 lines will not be shown a) Not initialized b) recent restart of OH and c) Heal started but not finished (first heal can take some time). If the time stamp for the device is before the controller, but the XML is present it is either b or c.
  2. under the UI tab for the device has this field been populated?
  1. Do you have the nightly network heal “disabled” or set to a time?

Need to eliminate some potential issues first.


The device should have been paired while the Zstick was connected to a running OH and the inbox was in scan mode (Plus sign–>Zwave binding —> Scan (while following the device “inclusion” protocol)) Is that what you did?

No, I connected it with the stick disconnected from the computer. It seems like it found its way to the Inbox anyway, so I added it. Not sure if I should continue answering your questions if that’s my answer.

Doing it that way could explain initialization issues.

Still need to figure out where the device is in the initialization process. It may not be done.

If it is initialized (not sure it is without the other questions), next step is to put the zwave binding in Debug and try to change your config and see what it says.


I removed it and re-added it with Scan mode, with the Zwave controller connected to the computer. It shows up as node 7, but the node 7 xml file isn’t showing up after I refresh Winscp. Any suggestions?

Network heal is set to 2am.

Then it is not initialized. Try the wakeup procedure shown above a few times. it is probably time to set the zwave binding in Debug to see what is going on when you press the wake button. Have you done that before? The file tends to get long, so set Debug, wake maybe 10 seconds apart, maybe 3-4 times and then return the Zwave binding to INFO. That should be enough for a start.

There is a zwave debug log viewer here (if you didn’t know that already)

For context how many nodes do you have and see .xml files for? Do you have main powered nodes?


Hi, Bob. I think it is properly initialized now. Node 7 shows on the network map and the device is showing up in the debug log when I push the buttons (when the device is near one of the relay nodes).
openhab.log (70.2 KB)

But it isn’t triggering my Rule. This should work, shouldn’t it?

Log file looks good-fully configured.

I do not have the device and use DSL rules, so a little hard for me, but my guess would be “when” statement can you add a “logwarn” to see how the Scene 3 is activated? I do not see “on” in the log maybe an “=3” ?


I’m not sure what you mean. I don’t quite get how to write DSL rules. Does one go to Scripts:New Script(+):Rule DSL? Is that where I need to add a “logwarn”? Please break it down for me.

Forget about my comment. I write my rules using DSL. It is an older version to write OH rules. You are using the more recommended newer approach, but I don’t have experience with it. Also since I do not have the device I’m unsure of what channel you are using

What I was trying to say is I think that you need to trigger on a number.
For me this would look like:

 Item Scenenumber3 changed
var Scenenumber3.state as Number
logWarn("events", "Print out Scenenumber3 {}", Scenenumber3)
if( Scenenumber3 == 3 ) {
    //dim lights

You will have to modify, but hopefully this will help or someone more familiar with the UI rule engine can help.

Sorry Bob

I figured out how to get scripts (DSL, I think) into the rules.

So I set the trigger, using the UI, to ZW130WallMoteQuad_SceneNumber1 changed.
Then I have a script that runs:
logInfo(“System”,“wallmotetest activated.”)
logInfo(“DEBUG”, "info 1: "+ ZW130WallMoteQuad_SceneNumber1.state )

the log lists:
info 1: NULL

And only when I run the script manually. I know that OpenHab is receiving a value from the WallMote, because the debug logs say (among other things)

NODE 7: Got a value event from Z-Wave network, endpoint=0, command class=COMMAND_CLASS_CENTRAL_SCENE, value=3.0
NODE 7: Updating channel state zwave:device:f71779d3f4:node7:scene_number to 3.0 [DecimalType]

(In this case I pushed button 3, but it changes from 1.0 to 4.0 depending on the button pushed.

So how do I get a rule to detect that change and respond to that value?

I tried to use “when a trigger channel fires” as a trigger, but there are no channels in the list of channels. Maybe that’s part of the problem?

I’ve tried all of these as triggers, and none of them cause the script to run.

Also, I’m wondering if I should start another thread for this, since my original question got solved. Thanks for your help, Bob!

Sorry to have to cut out, but it was late. I do think the new thread is a good idea because you really need someone with the same device to lead the way. Also the scripting needs one of the experts.

My only thought this AM is whether the “Item” linked to the “Channel” is a “Number”. For example;

The log file indicates everything is working, it is just the getting the channel to update the item .


1 Like

Thanks again, Bob. I created a new thread here: