Trying to add ZD2105 device to network


I am trying to add this device to my network:

I tried multiple times but couldn’t get it successfully added. When I opened up the jar file, I couldn’t find a ‘zd2105.xml’ file in there but when I checked the database online, it showed up:

I am using a pretty new version of the binding:

Any idea what could be wrong? Is the device not supported on OpenHab1.x? Here is snippet of the log when I try to include the device:

[ApplicationCommandMessageClass:40 ]- NODE 30: Application Command Request (ALIVE:MANUFACTURER)
[ApplicationCommandMessageClass:58 ]- NODE 30: Incoming command class MANUFACTURER_SPECIFIC
[nufacturerSpecificCommandClass:65 ]- NODE 30: Received Manufacture Specific Information
[nufacturerSpecificCommandClass:85 ]- NODE 30: Manufacturer ID = 0x0109
[nufacturerSpecificCommandClass:87 ]- NODE 30: Device Type = 0x2022
[nufacturerSpecificCommandClass:89 ]- NODE 30: Device ID = 0x2201
[.z.i.config.ZWaveConfiguration:288 ]- NODE 30: No database entry: Vision Security [ID:2201,Type:2022]

In OH1, you don’t need a database entry to use a device, and it’s certainly not need for inclusion into the network. The database is only needed for configuration, and in this respect it looks like this device isn’t in the OH1 database and will need to be added.

Hi Chris,

OK. So, maybe this is a stupid question, but how do I use the device in this case? I have only ever used Habmin to include/configure my previous devices and, in this case, the association group does not get populated under Habmin so I cannot select my controller (Sigma Designs UZB) as a member, so I don’t get any notifications when the device status changes. I added these to the items file and I don’t see it coming up in the events.log when I trigger the device:


(The rules were copied from another device I have, ZD2102 (same company, door/window sensor).

I guess I need to figure out how to populate the association group for this node. Is that possible to do manually?

If you need to do configuration, then as I said earlier, the device will need to be added to the database. I will try to add it later this evening unless you fancy producing a PR for this…

Thanks Chris. Yeah, it would be great if you could add it to the database.

Done - this should be in tomorrows snapshot…

Hi Chris,

I tried it today and verified that it is working.

Thanks a lot!