Trying to get my first binding working (Plex)

EDIT: I’m a new user so can only put in 2 links. httx == http. Sorry!

I’m totally new to open hab (and pretty new to linux) so I’m struggling a little bit!

I followed the guide here and installed my plugins using apt-get as they suggested, but there is no /addins folder under /etc/OpenHab/ so I don’t know if it installed correctly!

Long and short of it the sitemap is showing my plex commands, and pressing the buttons is not working. I can’t see any errors in the logs I can find in /var/log/openhab so I’m at a bit of a loss.

I did add in the plex:username, plex:email and plex:authenticationToken settings into the openhab.cfg as per the suggestion in this forum post: Plex Binding on Plex Home setup (which should probably exist in the wiki httxs:// I’m guessing!)

Any help would be awesome!



It looks like I only have 1.7.1 installed for the plex binding (not 1.8) so I’m guessing this could be my issue

Still not sure how to get version 1.8!

Ok, addons are installed in /usr/share/openhab/addons. And Plex 1.7.1 is in there!

Found version 1.8 here:

After upgrading to it nothing has changed - perhaps I need to reboot the server?!

Sorry for the running monologue, but hopefully it will help someone in the future.

a reboot sort of fixed it - it doesn’t look that reliable as it appears to keep everything paused. Anyway, I’m further now than I was!

Make sure you only have one plex binding jar file in the /usr/share/openhab/addons folder at any time. Look at your /var/log/openhab/openhab.log file for anything suspicious.

@rossdargan: You need the plex:password settings in openhab.cfg as well.


1 Like

Odd, it appears to work without that in there (I’m using the 1.8 binding and have the auth token in there instead).

Looks like that was what I was missing! thanks!