TTS for RPI (Pico TTS)

Hi everyone

i recently saw a video (Linked Below) of @Kai talking about a cloudless smart home in that video he demoed his system talking through the rules using a say command (@32:35)

in the video he was using a mac computer but mentioned this was also possible on a raspberry pi using software pico tts

could anyone give me pointers on how too set this up i need too replace my current tts solution

I have installed pico TTS

What are you currently using for tts?

Hi @H102

Two separate apps on a desktop machine it works but is not as easy as a dedicated tts solution

Type text into first one save as wav
Run convert to mp3
Use the chromecast binding too send audio too the Google home

Yea, that sounds like a pain.:roll_eyes: Did you install the jar file for Pico?

I used the apt get install method as linked in the docs

Doc’s say there is nothing to configure?
Here’s the jar file if your interested.https://openhab.ci.cloudbees.com/job/openHAB2-Bundles/lastSuccessfulBuild/org.openhab.voice$org.openhab.voice.picotts/

That’s the solution after downloading the .jar and putting it in my addons folder the options to select pico tts from paper ui were made available

Thanks for that :slight_smile:

1 Like

I wasn’t sure what all was included in the apt-get download. Glad the jar file helped and you got it working!:+1:

I submitted a PR to update the documentation to include downloading the .jar file for options access via PaperUI.

1 Like

why was the jar file needed ?

Not sure, but I doubt your the only person that may need to include the .jar for this addon.
What version OH are you on?

I’m running Openhabian on a RPI3 B+ its the latest version stable 2.3.0-1 all up to date using apt update ect

openHAB 2.3.0 was released on May 28, 2018 and does not contain the Pico TTS addon.
The Pico TTS addon was added when PR #3125 got merged on July 27th, 2018.
So it’s only part of the 2.4.0 SNAPSHOT/Milestone builds.

1 Like

I know this is an old thread, but I found it while searching to resolve my problem:

Setting up Pico Text To Speech for Raspberry Pi OS Debian Buster

openHAB 2.5.6 Release Build, I’m using a RasPi 4 with an openHABian install.

The Log viewer kept on detailing 'Error while executing '[Ljava.lang.String;@3a9523'...' and something like error 2 picotts2 file not available/found.

This is is how I solved it.

Edit ‘addons.cfg’ by adding picotts to the voice services. I’m only using one service so my file has a line that looks like this:
voice = picotts

or via the Paper UI; select the ‘Add-ons’ menu, ‘Voice’ tab and select install Pico Text-to-Speech.

Unfortuately this is not all that is required the openHab documentation

says to install libttspico-utils, but this does not work out of the box because there is a policy to not build contrib/non-free into Raspbian. See here

However the above site also documents a method to install libttspico-utils that I quote below.
Login via SSH to your RasPi and type / cut and paste the following commads.
if you run into problem with needing to be root use sudo su root for that command and use exit to return to the openhabian user

wget -q https://ftp-master.debian.org/keys/release-10.asc -O- | apt-key add -
echo "deb http://deb.debian.org/debian buster non-free" >> /etc/apt/sources.list
apt-get update
wget http://ftp.us.debian.org/debian/pool/non-free/s/svox/libttspico0_1.0+git20130326-9_armhf.deb
wget http://ftp.us.debian.org/debian/pool/non-free/s/svox/libttspico-utils_1.0+git20130326-9_armhf.deb
apt-get install -f ./libttspico0_1.0+git20130326-9_armhf.deb ./libttspico-utils_1.0+git20130326-9_armhf.deb

This worked for me, try it if you are experiencing similar problems.

You can use the Console to test it out, this is documented here:


And how to use the console is documented here: