Turning of Autodiscovery!

I use a RPI 3 with latest Openhabian and for examle the RFXCOM-binding produces a LOT of things in the inbox, (over 2000 in a couple of months).
I found this: [https://docs.openhab.org/concepts/discovery.html#background-discovery] and tried to put this line
in /etc/openhab2/services/runtime.cfg and restarted OH but it did not stop to discover .
What should I do?

I guess you need to set disableDiscovery to true in your bridge config:


Thank you for answering :slight_smile:
But I think that what you are refering to is the unknown (unencoded) protocols (but not sure):

I refer to the official OH doc. it would be great to state where you should put this “command”?


Thanks for answering.

I would greatly appreciate If some with knowlegde about the offical documentation could answer?

The description of that switch on the bridge Thing is correct. It disables discovery of unknown devices. Turn it on and messages for devices that are unknown will be discarded instead of used to create entries in the inbox.

My question is how I can totally disable Autodiscovery from rfxcom, I will just enable it when adding New ting…
If you looked at the URL further up its explained but not for me as a newbie :hugs:

Did you try to use that switch? From the description it will exactly dowhat you want.

The switch should be located in the binding configuration section …

does that switch exist in every binding? i don’t find it, but would like the hue binding to shut up :slight_smile:

If you did configure your HUE things manually, you should set “Auto ignore” to true to get rid of any autodiscovered things …