[Tutorial] Installing Razberry Board under Raspbian Jessie

Tags: #<Tag:0x00007efeda3a1c88> #<Tag:0x00007efeda3a1b70>

Hey folks,

after trying to get my new razberry board working for the last two days and see that other people dealing around with similar problems, I thought I write a short description how I get my razberry up and running.

My environment:

  • RP2 with Raspbian Jessie
  • OpenHab 1.8.3
  • Razberry Board installed on my pi
  • User is openhab

To get the razberry sister board working do the followings steps:

  1. Copy Binding:
    First of all you have two copy the z-wave binding org.openhab.binding.zwave-1.8.3.jar to your addons folder <openhab-folder>/addons.

  2. Edit openhab.cfg:
    Open the configuration file by typing sudo nano <openhab-folder>/configurations/openhab.cfg.
    In the file find the section ##### Z-Wave Binding ##### and set port configuration to zwave:port=/dev/ttyAMA0.
    Save the file and exit nano with CTRL+O & CTRL+X.
    /etc/ttyAMA0 is the device file to access your GPIO Pins on your pi.

  3. Add user openhab to groups:
    To access the file the user openhab has to be member of the groups dialout and tty.
    So enter sudo usermod -a -G dialout openhab and sudo usermod -a -G tty openhab on the command line.

  4. Change the start script:
    To give your openhab process access to /dev/ttyAMA0 you have to edit your startscript with sudo nano <openhab-folder>/start.sh.
    Find the line -Dosgi.noShutdown=true \ and add the following line right after:
    -Dgnu.io.rxtx.SerialPorts=/dev/ttyAMA0 \.
    Save the file and exit nano with CTRL+O & CTRL+X.

  5. Change device write setting:
    The last step is to edit the write access to the device file (this step costs me hours to find).
    Type sudo chmod g=rw /dev/ttyAMA0 in the command line to give group members read+write acces to the gpio port.

  6. Restart your PI:
    Restart your pi with sudo shutdown -r now

After that the Razberry should work and you can start to configure your Z-Wave Network. If I forgot a step or something is unclear, please let me know.

Cheers,
Christian

… be aware that you have to disable the serial console by using raspi-config.

Mmh. You shouldn’t need to copy the bindings if you use the openhab packages for Raspian. That’s part of the standard installation instructions for openhab and valid for any of its bindings.

Also mention to not install the z-way software or to disable it afterwards.