Tuya smart plug has no IP

I have registered at iot.tuya.com and can see all my tuya devices listed. I have also been able to connect two tuya light bulbs to OpenHAB 3.4 with the smarthomej tuya binding. I have a Nedis branded Tuya smart plug that works fine with the Smart Life app and I can see it with tuya-cli wizard. Smarthomejs binding finds it and lets me configure it, but the switch does not get an IP number and complains about that. I can not see the switch on my router at all, but I can still control it with the Smart Life app on my phone. How is this possible and how do I find the IP of the switch?

Very strange. Have you tried looking on your router for the MAC address of the switch? Are you using IPv6 or IPv4? I have quite a few Tuya devices and have never experienced the behavior you are describing. I have a couple of devices with older firmware where I had to manually enter the IP address in the binding, but that isn’t your problem.

Double checked this this morning. I have two wireless routers: one for phones and web browsing and another for IOT. Apparently I had forgot to change the network on my phone when setting up the switch and it ended up on the “web router”. Once I logged onto the “web router” I found the mac there. I re-registered the switch with the phone app to the IOT network and now it works as it should.

1 Like