Two Factor Authentication of Amazon Echo Control Binding vanishing in 3 Seconds

I’ve installed the Amazon Echo Control Binding and created an Amazon Account thing. In the configuration page it sais “Please login in through web site: http(s)://:/amazonechocontrol/7xxxxx82”, which in my case translates to http://openhabian.fritz.box:8080/amazonechocontrol/7xxxxx82. An Alexa sign-in page opens, allowing me to login with my Amazon account credentials. After login (1) Amazon is sending a 6 digit code to my smartphone and (2) in my browser an entry screen for entering this code will show up for 3(!) seconds and then will go back to the Alexa sign-in page again. I’ve tried for about 10 times, but never made it in 3 seconds to enter the 6 digit code and press the confirmation button. Am I just too slow? Is there a way to extend the entry time for the 2FA?

Thank you for constructive ideas and comments.

  • Platform information:
    • Hardware: Raspberry Pi 3B+/1GB/64GB
    • OS: Openhabian v1.7.5/32 Bit
    • Java Runtime Environment: 11.0.16
    • openHAB version: 3.4.0
  • No rules setup yet
  • In the log an error is shown: com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 8 column 1 path $ at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$Adapter.read(ReflectiveTypeAdapterFactory.java:226) ~[?:?]

Ok, I found it myself - maybe it helps somebody else. I’m a bit embarressed as it mentioned in the instructions (altough it’s hidden under “more”): “If you encounter redirect/page refresh issues, enable two-factor authentication (2FA) on your Amazon account.” That did it for me.