Ubiquiti Unifi Binding Feature Discussion

ubiquiti
unifi
Tags: #<Tag:0x00007f01487cbd48> #<Tag:0x00007f01487cbc08>

(Thefathefa) #404

I have to say that this is one of the key elements of my Openhab setup. It works very well and it is very useful. Thanks,


(Matthew) #405

@Crispin @jwiseman @thefathefa Happy to hear it!

I swear to you gentlemen that I am going to pick this binding back up, but I’ve just been so busy with my house I barely have time to sleep… rubs eyes


(J Wee) #406

“4 In-Ceiling PoE powered Echo Dots (which are fed into the In-Ceiling speakers using a ducking mixer - I don’t use the built-in speaker)”

Wow, exactly how did you wire the Echo Dots to your in-ceiling speakers?


(Matthew) #407

Each Echo Dot has 2x CAT6A cables ran to its location:

  1. PoE Adapter
  2. Audio over Ethernet Adapters: Echo Side + Mixer Side

Before pulling the trigger, I bought a pair of the audio adapters and tested it with 100m cable and it worked fine. All the In-Ceiling speakers are wired directly into the mixer.

Got the inspiration from a Reddit thread.

This is also one of the WAF requirements for PoE support in the UniFi binding. I have to be able to “kill” the dots by turning off their PoE via the UniFi switch in case we want to have a private conversation in the house

“Alexa, commit harakiri”

:smiley:


(Pumbadinho) #408

Any update on adding to repository?


(Craig) #409

Hey all, add me to one keeping a keen eye on this development. Sounds like it will be amazing


(Kristof Rado) #410

Hope someone can help me here. I want to develop my current network and I come up with Ubiquiti - besides that it has a working binding for OH. However if I want to use this binding, should I need the UNMS software running somewhere or it use (for example) an EdgeRouter directly?

If UNMS is required, what hardware do you recommend installing it, what do you use?


(Mark) #411

I’m not familiar with the UNMS software. I think that is relatively new. The Unifi binding works with the Unifi Controller software.

I manage my 2-site network using the Unifi controller software (v 5.8.30) running on an Ubuntu Linux box. I have 9 APs (AP-AC-LR, AP-LR, and AP-AC-Mesh) and one US-24-250W switch all of which are managed by one controller instance running in one of the sites.


(Kristof Rado) #412

Thanks! Which hardware do you use to run UniFi controller? An RPi should be enough for a smaller network?


(Mark) #413

You should have no trouble running it on an RPi. In my case, I have a number of services (including the Unifi Controller) running on a core i5 1U rackmount server.

Your other option would be the Cloud Key, but I don’t have any experience with that.


(Kristof Rado) #414

Thanks for your help! I’m also thinking of buying a ‘real’ server for these purposes, but I don’t know which way would be good. I live in a flat, so I don’t have much space for servers. What other services do you run on your server? I might want to use it as a file server (NAS), run openHab and UniFi Controller. (and maybe smaller services as well…)


(Mark) #415

I run Zoneminder, Zabbix, and a few other services.

I built my rackmount server based on this article. As described in my comments on the article, I deviated a bit from his specs to reduce the cost by several hundred dollars.


(Kristof Rado) #416

Thank you very much for your help! Really appreciate it!


(Mark Lavercombe) #417

I run the controller software on my synology NAS


(Matthew) #418

Hey all, I still don’t have any spare time (it’s all spent at the house) but I will get back on this as soon as possible.


(Psyciknz) #419

Anyone have this binding stop working on 5.9.29 unifi version?

when i turn on debug logging, I see the wireless devices show up at Wired= true…and then it doesn’t find any devices even when I can see in the client list the mac address listed for my thing.


(Mark) #420

I just installed 5.9.29 a few minutes ago. Let me take a look…


(Psyciknz) #421

Ta. I’ve got another linux script that reads the api, and it;s showing the devices as wired/wireless correctly (and so is the unifi ui).

I just wonder if the binding it only looking for devices where wired=false … maybe?


(Mark) #422

All my wireless devices are showing up as wired: false

Yes, I’m pretty sure it looks for wired: false. I could check the code, but I recall that being discussed in this post a while back.


(Psyciknz) #423

So here’s my device.

09:41:46.056 [DEBUG] [inding.unifi.internal.UniFiController] -   UniFiClient{mac: 'xx:xx:xx:xx:xx:23', hostname: 'lumi-gateway-v3_miio87296016', wired: true, device: UniFiDevice{mac: 'xx:xx:xx:xx:xx:xx', name: 'AP-Cupboard', model: 'U7LT', site: Site{name: 'Nazgul', path: 'default'}}}

See it says wired: true…and then posts the ap it’s connected to.
Then later on says it can’t find the device

09:41:46.548 [DEBUG] [ding.unifi.handler.UniFiClientHandler] - Refreshing channel = unifi:client:nazgul:unifi_xiaomi:lastSeen
09:41:46.552 [DEBUG] [ding.unifi.handler.UniFiClientHandler] - Could not find a matching client: mac = xx:xx:xx:xx:xx:23, site = Nazgul

All the other things I’ve defined exhibit this behaviour…but in paper UI the device lists as online.