Ubiquiti Unifi Binding Feature Discussion

Hello,

i would like to use the Unifi Binding, but it seems like 2FA is actually not supported. Are there plans to integrate 2FA?

Alex

I think the way to do it for now is to create another user, e.g call it “read only” and do not require 2FA for that user. That way there’s no security risk that that user can change some setting or do something critical.

Good idea, i tried it out and the read only access works fine so far. Just hoped, i can control my wifi’s etc. with the binding. I think this will not be possible with read only access.

I’m a tiny bit confused with all the versions and different products going around. Especially since the OS of the CloudKey has recently changed with a firmware upgrade.

I have the CloudKey 2+ with firmware 2.0.24. I have managed to connect the unifi protect binding.

Should I be able to connect this binding as well or does the UDM/Pro login solution need to be implemented first? I’m just not sure if I have some solvable error or if I’m just wasting my time for now.

I suspect you can’t use it. There is a dev version floating around that might work, since I’m not running unifi anymore i cant confirm

1 Like

I have the CloudKey 2+ with firmware 2.0.24. I have managed to connect the unifi protect binding.

How did you manage?

I cant get the controller binding to work…

When I switch from 8443 to 80 I get

CONFIGURATION_ERROR
Error establishing an SSL connection with the UniFi controller

and when I switch to 443 I get

COMMUNICATION_ERROR
com.google.gson.stream.MalformedJsonException: Use JsonReader.setLenient(true) to accept malformed JSON at line 2 column 12 path $

@redbear-ger You misunderstand. I successfully got the “Unifi Protect” binding to work with the CloudKey.

I suspected CloudKey+ with the new >= 2.0.18 firmware does not currently work with the regular Unifi binding yet which also @Seaside somewhat confirms.

@Seaside has implemented the proper authentication for the Protect binding but no such solution seems to exist in the regular one.

A bit more info here.

Ah I see, thx for clarifying… and the Protect Binding isnt available for 3.0 yet.

It is only in alpha so it’s not in the addon repo yet. Anyway it’s only for the protect series of products such as cameras. Hopefully someone can migrate the login from that binding to also work with this one.

Hi Matthew,

any update so far? I was wondering if we can have all the features of #132 + Experience feature in the latest stable release of OH. There are online from quite some time, and I think it should be stable enough.

If you need a good tester, let me know … I’ve a lot of Unifi devices at home.

a huge THANK YOU for your effort & support

Andrea

Hello,

will i be possible - in near future - to access the whole API with the Unifi Binding like it is possible with ioBroker?

Because there are a few bindings that are not supported by openhab, yet, i am thinking about setting up a separate ioBroker instance and link this with MQTT to OH3, what would mean some manual work.
If there is a chance to access the data soon, it would wait to avoid the manual work.

After ugrading my " UniFi Cloud Key Gen2 Plus" i get an 404 error connecting via OH3 unifi controller bridge.

I have an UDM and cannot connect the controller with openhab (2.5.11). Unfortunately it has never worked with the UDM.
I always get a communication_error.

With the controller on the Raspberry (before) it always worked. Can someone please help me?

Hi, I’m having the same issue now. Updated my Unifi Controller 2 days ago and realized today that openHAB isn’t able to communicate with it now. Is there any solution meanwhile to get that back running?

Hi,
I also have since several days after updating my Unifi controller towards software version 6.0.43; that the Unifi binding cannot communicate with the controller anymore. I get the following error with Unifi snapshot build 2.5.5:

'unifi:controller:home' changed from UNINITIALIZED (HANDLER_MISSING_ERROR) to INITIALIZING

2021-01-10 14:46:01.356 [hingStatusInfoChangedEvent] - 'unifi:controller:home' changed from INITIALIZING to OFFLINE (CONFIGURATION_ERROR): Invalid hostname - please double-check your configuration

The hostname (IP-address) has not changed, and I can still manually login with the openhab account on my Unifi controller.

Unfortunately, they changed the way how to communicate with the Controller
The binding is also not reflecting the new two-factor authentication :frowning:

Hopefully, the author of this binding can help to get it back to work

the same does not work rasberry Pi openHAB 3.0
UniFi Cloud Key Gen2 software version 6.0.43

Unifi ctrl 6.0.43 + Openhab 2.5.x working fine for me (just upgraded to .43 though…)
2FA is not essential, just add a read-only user without 2FA.

Hi,
I did a quick change of the Unifi binding using Seaside implementation for Protect login.
Thanks Seaside for the protect implementation.

Consider it like pre-alpha, Im only using it to have presence of mobile devices, its built for openhab 3.0.

Link to the binding
Link to repo with example how I use the binding

4 Likes

Hi Patrik,

thanks for working on this binding!!
Since it is a v3.1 binding, please let me ask if it also will work with v3.0 stable or is there any trouble expected?

Regards,
Sascha