Unable console login using id_rsa.pub

Hi, decided to optimize the logining to openhabian using ssh to the server with the working machine. Generated id_rsa.pub on a working machine and copied it to authorized_keys. The logining to openhabian the system is working fine.
But after that there is no way to login OH console. When entering ssh -p 8101 openhabian@localhost all the time asking for the password. As soon as I delete a line from authorized_keys the password is accepted and I can work in the console. What setting do I need to make both options work?

They shouldn’t interfere with each other at all. But it is possible to configure the ssh client to not allow password logins. Do you have PasswordAuthentication no in /etc/ssh/ssh_config? If so then you are telling your ssh client that it isn’t allowed to log in with just a password.

If you are trying to log into the console with your SSH key instead of the password, then you need to add your key to the karaf console config. See Security of Karaf console