Unable to connect to my openHAB pi

Hi I’m Brand new to openHAB but reasonablely competant with Raspberry Pi and Linux.

I have tried several times now to get openHAB workiing on a Pi the Build seems to go OK. While th build it taking place browsing to port 80 displays the build log refreshing ever 10 seconds at the end of the build it says the build was good and that after the reboot browse to port 8080 when I try that I get connection refused.

ssh -p 8101 also gives connection refused

I connect a Monitor and Keyboard everything looks fine but I can’t login as openhanded:habopen don’t work.

about-the-beginners-category/34 Says:-

Before Posting

  • Read the openHAB 2 documentation . Most beginner problems originate out of an incomplete understanding of the openHAB basics described there.

I’ve looked at that but in fact docs.openhab.org is not in the DNS so that’s not much help to me.

Does anyone have any pointers to documentation that might help resolve this issue for me.

Also the limit on the number of links in a post doesn’t help me describe the problem correctly.

It’s Introduction | openHAB for quite some time now. Should be updated in the forum software I guess.
I think you went the recommended “openHABian” way? So, the docs for that are here:

  • ssh ( use standard ssh port 22 ) into your pi using the openhabian account
  • then sudo bash and go to /var/log/openhab
    there check the content of the openhab.log file for errors
  • besides that you can check if a java process is running ( ps -ef | grep java )

Thank you for the pointer to the Docs. Yes I am using openHABian.
I’ve now able to log on and can start digging.

1 Like

Hmmm /var/log/openhab only has an empty Readme.txt

There is no Java running either.

Looking at first-boot.log
Installing OpenJDK 11 Failed
Installing selected openHAB3 Failed
Installing Samba Failed

No wonder it’s not working.

yes. I had similar outcomes, when I fiddled somehow with the openhabian-installation: e.g. logging in ssh, opening webserver, …
So my advice would be: put a vanilla SD Card in, at best connect the raspberry pi via LAN-cable and let it do the magic for an hour or so. Then it should be ready (depending on the generation and your internet speed). Now re-installing some of the above packages didn’t work out for me, as somehow openhabian itself didn’t find the correct links? :woman_shrugging:

If you used an external SSD instead of SD-card the "magic " will only take about 5 minutes.

Hello tried to install openhab 3 today, got exact same results as brambled, when i try to start openhab it complains about karaf… Did the installation from a clean memory card with the Raspbian tool thingy…

The problem seems to be that for some reason Java wont install :-1:

$ sudo apt install default-jdk
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
default-jdk is already the newest version (2:1.11-72+b4).
0 upgraded, 0 newly installed, 0 to remove and 54 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up ca-certificates-java (20190909) …
head: cannot open ‘/etc/ssl/certs/java/cacerts’ for reading: No such file or directory
Error occurred during initialization of VM
Server VM is only supported on ARMv7+ VFP
dpkg: error processing package ca-certificates-java (–configure):
installed ca-certificates-java package post-installation script subprocess returned error exit status 1
Processing triggers for ca-certificates (20210119) …
Updating certificates in /etc/ssl/certs…
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d…
Error occurred during initialization of VM
Server VM is only supported on ARMv7+ VFP
E: /etc/ca-certificates/update.d/jks-keystore exited with code 1.
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ cat /proc/cpuinfo

processor : 0
model name : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 697.95
Features : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7
Hardware : BCM2835
Revision : 0010
Serial : 000000004c3cf831
Model : Raspberry Pi Model B Plus Rev 1.2

From what I’ve read openHAB should run on a B+

So I’m now stumped.

Is there any possibility to change the java version to zulu in the openhabian.conf? Since this seems compatible ARMv6.

After installing on a Pi4 it seems to work

Zulu was removed from openhabian but technically speaking you can do it manually.

I ended up doing a stock Raspbian with manual installation. Worked fine so far :slight_smile: