Unable to control WeMo switch


I am having great difficulty in configuring a Wemo Switch to work with OpenHab2.

I can control the switch from the Belkin app on my phone and/or tablet. I can ping the wemo device from the RPi that OpenHab is installed on. I can control the switch from a script on the same RPi, so I am quite confident that the Wemo is installed correctly and can be seen / controlled from the RPi.

I have installed the Wemo Binding from the PaperUi. The Wemo switch is discovered and shown in my inbox, so I have the socket address for it.

When I try to control the switch from HABpanel, I get no response from the wemo, but the switch on the HABpanel changes.

Viewing the karaf log, I see the following:

00:07:16.155 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘DemoSwitch’ received command ON
00:07:16.328 [INFO ] [smarthome.event.ItemStateChangedEvent] - DemoSwitch changed from OFF to ON
00:07:18.154 [ERROR] [home.binding.wemo.handler.WemoHandler] - Failed to send command ‘ON’ for device ‘wemo:socket:Socket-1_0-221246K1100815’: Could not call WeMo
00:07:18.387 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘wemo:socket:Socket-1_0-221246K1100815’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR)
00:07:18.553 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘wemo:socket:Socket-1_0-221246K1100815’ changed from OFFLINE (COMMUNICATION_ERROR) to ONLINE

Items entry as follows:

Switch DemoSwitch { channel=“wemo:socket:Socket-1_0-221242K1100815:state” }

Things entry as follows:

wemo:socket:Switch1 [udn=“Socket-1_0-221242K1100815”]

I have tried both creating and binding via the PaperUi, and via manual entry, both with the same result in the karaf log. I’ve tried plenty of searching an examples from both here and elsewhere on the net, but have still run into a brick wall.

Any help would be greatly appreciated.

Could you please give some more information about your openHAB server ( OS, detailed Java version)

OS is raspbian-jessie with latest updates running on a RPi 3.

Java version:
java version "1.8.0_65"
Java™ SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot™ Client VM (build 25.65-b01, mixed mode)

OpenHab Stable version 2.2.0-1

Thanks for taking the time to help.

Your Java version needs an update.

Your question about which Java version I was using made me go and try Zulu - to no avail. It wouldn’t even recognise the switch at all once I had tried that. I also tried purging OpenHab and trying from scratch, also to no avail - several hours lost there.

Lastly, I thought I would try completely burning everything and starting from scratch. I have installed OpenHabian as a brand new install, and it picked up the Wemo Switch as soon as I added the binding, and will control it - win!

Thanks very much for your time and effort, I now have it working.