Unable to create resource for bundle Error

I am working on a twitter binding for openHAB 3 and I cannot get the twitter4j dependency to work when building with maven. I get the following errors.

“Unable to create resource for bundle mvn:org.twitter4j/twitter4j-core/4.0.7”


<bundle dependency="true">mvn:org.twitter4j/twitter4j-core/4.0.7</bundle>



I also tried launching the code in Eclipse and I get a cannot resolve dependency error.

Scott Hanson

If you use scope compile you don’t need to add it to the feature file, because with compile the code of the library is included in your binding.

I tried it before without the bundle dependency in the feature xml and it didn’t work either.

What error does it givein that case?

I just noticed its different, after I removed it again.

missing requirement [org.openhab.binding.twitter/] osgi.wiring.package; filter:="(osgi.wiring.package=android.os)"]]

You could try adding bnd.importingpackage to ignore these kind of dependencies…For example see: openhab-addons/pom.xml at ecac66725851ad6fd511de2d3dcb35517e574313 · openhab/openhab-addons · GitHub

I reran it again and I get the first error now. It seems very random.