Unable to disable parameters

I’m not really sure if this is a binding problem or an UI problem, but I’m trying to disable periodic reporting of some values on some of my Z-Wave devices and it won’t let me.


To disable the reporting I’m supposed to set this parameter to 0, but setting it to anything below 5 gives me the error (which is swedish for “Choose a value that is no less than 5”).

The device in question is a Hank HKZW-SO05.

Whoever entered that item in the database made an error. I just corrected it in the database and a snapshot binding with the new database should be available in about a week.

1 Like

I suspected it was something like that. Thanks!

Follow-up question: Is there any way to see in the database what the limits for parameters are set to?

I believe if you have an account there you can be able to see them. I know if you have database write access you can.

@chris would know for sure. I think the old site you could see without login.

Hmmm… I had an account on the old site. Tried to reset my password according to instructions now, but never got the reset mail…

Anyway, I’ve got another case, what do you think about this one?

If I understand the instructions correctly it’s supposed to take a numerical value, but I can’t seem to change it at all. Also something wrong in the database? It’s a Qubino 3-Phase Smart Meter.

Database entry looks fine to me. What version of OH? You might need to use a snapshot version of the binding. That entry was last updated on December 27 2020. Any snapshot after December 28 should have the latest changes.

3.0 release version. But it feels unlikely that this device has been changed lately in the database, it’s not like it’s a new device. I think I edited the settings for it in 2.5 without seeing any strangeness (not 100% on that one though).

edit: I started digging in the xml-files, this is en extract from the file of that node. It says it’s an int…


OK it was definitely changed after 3.0 was released. There is a 3.1.0-SNAPSHOT binding.

There was an issue corrected where many items were restricted to options though and that one has only 1 option.

Ah, ok! I’ll make an update then and stop whining :wink:

1 Like

You will then likely need to delete & re-add the Thing to OH to get the new settings.

1 Like