Unable to lock/unlock zwave lock Kwikset 910

I have a kwikset 916 for the sheer purpose of remote unlock on openhab2 (I bought a pine64 for this purpose), is there any way we can get to test this build? I have the red light too and get no unlock.

Follow this thread -:

Sorry - I don’t know what this is :confused:

Also I read it somewhere else that a code manager in OH is a feature to be worked on. Is this in progress as well? I’d like to be able to manage some advanced configuration remotely.

Sorry - what is a “code manager”?

Sorry Chris, I should’ve mentioned that I came from SmartThing world. A lock code manager provide a easy way to manage multiple smart locks, specifically allow you to define things like:

  • Assign Codes to Multiple Users.
  • Manage Multiple Locks.
  • See what codes are active.
  • See how many times a code is used (reset usage manually)
  • Be notified when a user uses their code.
  • Delete codes after they are used*.
  • Optionally Schedule Users so that they only have access during certain times, modes, days of the week, or a calendar range.
  • Decide which notifications to receive in the event that the locks are too chatty.
  • When a code is entered, perform Hello Home Actions.

See this Lock Code Manager

I think I’ll be pretty happy if I can somehow change the lock code remotely, and be notified who unlock the door (identified by different code). Other features are really just eye candy for me.

I’m in a pretty similar position with this lock. In another home automation software i’m running on my Pi 3, I can get the lock to pair, but when I do it, there’s a totally different button to do a Secure Include vs a regular Include. When I did it with the regular include it won’t actually send the commands and stuff once paired, but when I Exclude it, then Secure Include it, things work fine.

I tried to install OpenHAB2, kept the 2.1 Z-Wave binding uninstalled, added the 1.9 Z-Wave to the Addon, but couldn’t seem to get it enabled and working correctly. It would show as no Bindings available to find devices, even when I had the 1.9 listed as Installed… Is it possible to get these Secure Devices linked up properly in OpenHAB2, or do I have to use OpenHAB1? I’m happy to test out a development build if you have something that may work.


I would bet we could piece together most of this functionality using Sitemaps (would have to figure out text entry work arounds) and rules (or potentially as a module to HabPanel, though haven’t researched this at all). I’m currently integrating with my locks through my Vera using the Mios binding and it’s been pretty straight forward to setup the notification pieces for who unlocked, errors, outside locking events and managing lock/unlock conditions. Hadn’t played with the user/code management since I still have that functionality w/i my Vera, but will try to play with it in the next week or so (especially the temp code feature since that could be pretty useful).

OH1 bindings don’t show in the bindings list.

OH2 secure classes are still a while off unless you want to use the development version (please see my post from last night).

1 Like

Lucky you there is binding for Vera device out there. I’m currently using MQTT to communicating between SmartThings and OH2. Some devices (Zigbee, locks) are physically bound to ST, while rest (Arduino nodes, Zwave, 433MHz etc) bound to OH2. Through MQTT I can achieve to control all devices from both world. Not the best solution (MQTT does has tiny latency), but works for me so far.

Is the OH2 Development version the same as the 2.1 unstable one from 1/29?

No - see here -:

1 Like

Any updates here? I’m just getting started with OH2 and would love to have a secure deadbolt

What’s the question ;). Locks are working as per the link I posted immediately above…

whelp, I’m an idiot

I have a Kwikset 910 Z-Wave Contemporary SmartCode Electronic Touchpad which I am trying to get running in OH2 (build 978). I have a Aeon Labs Aeotec Z-Wave Z-Stick, Gen5 USB stick.

Installed the test binding into the addons folder today (
Unfortunately this version of the binding does not recognize the lock (the 2.2.0 Snapshot version does recognize it as 914TRL Touchpad Electronic Deadbolt). The system doesn’t generate a node file at all for this one.

Log file says:
2017-07-05 18:54:17.136 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - Initializing ZWave thing handler zwave:device:15a9b6d2cb3:node20.
2017-07-05 18:54:17.137 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 20: MANUFACTURER not set

I wonder which Kwikset model has been used by the other users?

[Update] After letting the system run during the night the node has updated and recognized the lock correctly.


i am facing same issue where the kwikset 910 is being recognized as TRL 914 and it does not work in terms of status updates, battery levels or open/ close commands.

Just downloaded the latest version of openhab2 as raspberry pi openhabian image so everything should e latest version (i think). I am just 3 days new to open hab :slight_smile:

the doorlock works perfectly with another similar automation system called Openremote and Gen5 z-stick

I have heard a lot of good things about openhab so want to give this a try.


That’s how the Kwikset gets recognized.

Make sure the lock was included securely. You can do that in HABmin by looking at the Thing attributes. The “Using Security” attribute should show a green checkmark if it’s included securely.

Thanks Mark, is there a way to force association using security enabled?
I don’t have the doorlock with as I am travelling for the next few days but i tried 2 other sensors (door sensor and remotec switch)- for both in Habmin under attributes security shows a “?”

i am wondering if I have to set a parameter somewhere so that the Gen5 stick will only perform secure inclusions?

In HABmin, select the Z-Wave Serial Controller thing. then select Tools->Advanced Settings.

On the Z-Wave Network Settings panel, Secure Inclusion Mode should be set to Entry Control Devices if you want to use security just for locks. I think this is the default. You can change it to All Devices if you want to use security for other device types that support secure inclusion.

As for the Kwikset, you may need to place the lock within very close proximity of the Z-Wave stick.

You may already know this, but you need to use HABmin to do the secure inclusion. You can’t do secure inclusion by removing the stick from the openHAB server.

Thanks Mark. I will try the lock in secure mode this weekend.

However i tried to connect another battery powered sensor in the secure mode and having no luck. I have another thread going as below; if yo uhave any inputs / thoughts / ideas on how to resolve this issue that would be great.