Unable to read data using the smartmeter binding


after updating my openhab installation to 2.4 I tried the new smartmeter binding to read data from my power meter (Landis+Gyr E650) using the IR reader from volkszähler project.

I receive the following error:

2018-12-29 15:18:43.461 [INFO ] [ding.smartmeter.internal.MeterDevice] - Opening connection to smartmeter:meter:power
2018-12-29 15:19:13.481 [WARN ] [ding.smartmeter.internal.MeterDevice] - Failed to read: The source did not signal an event for 30 seconds and has been terminated.. Closing connection and trying again in 2 seconds...; smartmeter:meter:power
java.util.concurrent.TimeoutException: The source did not signal an event for 30 seconds and has been terminated.
	at io.reactivex.internal.operators.flowable.FlowableTimeoutTimed$TimeoutSubscriber.onTimeout(FlowableTimeoutTimed.java:139) [234:org.openhab.binding.smartmeter:2.4.0]
	at io.reactivex.internal.operators.flowable.FlowableTimeoutTimed$TimeoutTask.run(FlowableTimeoutTimed.java:170) [234:org.openhab.binding.smartmeter:2.4.0]
	at io.reactivex.internal.schedulers.ExecutorScheduler$ExecutorWorker$BooleanRunnable.run(ExecutorScheduler.java:260) [234:org.openhab.binding.smartmeter:2.4.0]
	at io.reactivex.internal.schedulers.ExecutorScheduler$ExecutorWorker.run(ExecutorScheduler.java:225) [234:org.openhab.binding.smartmeter:2.4.0]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
	at java.lang.Thread.run(Thread.java:748) [?:?]

My thing configuration (…tested different settings without success):

smartmeter:meter:power [port="/dev/ttyUSB1", baudrateChangeDelay=250, refresh=60, mode="ABC"]

Btw: reading data using the script provided by https://github.com/ohitz/smartmeter-readout works perfectly fine with the following debug output:

DEBUG: Opening /dev/ttyUSB1
DEBUG: Sending sign-on
DEBUG: Reading identification
DEBUG: Read on serial port: `/LGZ5\2ZMD3104407.B32..'
DEBUG: Identification received: `/LGZ5\2ZMD3104407.B32..'
DEBUG: Upgrading to 9600 bps.
DEBUG: Receiving telegram.

Any help would be appreciated.

After upgrading to the latest snapshot and restarting RPi it currently works for some strange reason :slight_smile:

Hello hypetsch,
I am facing the same timeout problem.
Using the IR reader from Volkszaehler and will not get it running with OH smartmeter binding.

Using minicom I get result from the reader, but when I activate the smartmeter binding, latest stable version, I receive the same timeout error as you descibe.

Rebooting, unplugging, reinstalling the binding did not work for me.

I am somehow lost… hoping that a future version of the binding, will fix this “bug” for me.
Can anybode help in this case?