Unable to setup IDE - Windows 7 64bit

Tags: #<Tag:0x00007efecb672700>

Hi,

I am following IDE installation guide as per the instructions.

  1. Download the Eclipse Installer - downloaded 64 bit version

  2. Launch the Eclipse Installer and switch to “Advanced Mode” in the top right menu: - it asked to store the installation in the directory with check boxes to create short cuts.

  3. Choose the “Eclipse IDE for Java Developers” and select “Next”:

  4. Expand the “Github.com/openHAB” entry, double click “openHAB Development” (the double click is important: The entry has to appear in the empty table at the bottom). Furthermore double-click all entries that you would want to have available in your workspace (you can select multiple/all of them). Make sure that all of them are listed in the table at the bottom and select “Next”.


    - Choose openHAB Development, OpenHAB 2 Add-ons, opneHAB1 Add-ons, and ESH + OH2 Core Bundles. Not sure if all these are required. Which are the required selections?

  5. Now provide an installation folder (don’t use spaces in the path on Windows!) and your Github id (used to push your changesets to) and select “Next”. - choose default folder and left Github id to annonymous

  6. The installation will now begin when pressing “Finish”.
    see installation details:
    installation_log.pdf (119.8 KB)

  7. Once it is done, you will see the Eclipse Welcome Screen, which you can close by clicking “Workbench” on the top right. You will see that the installer not only set up an Eclipse IDE instance for you, but also checked out all selected git repositories and imported all projects into the workspace.

OpenHAB2 IDE is not building. Please see following snapshots:

Any pointers or help to resolve this issue?

Thanks

1 Like

No. Not so far. I do have the same issue under Windows 8.1.

I have tried to setup Openhab IDE following guideline in Fedora OS also. Getting setup problem like windows.

Any help to resolve this issue?

I’m having the same issue on Windows 10 x64. Has anyone found a fix for this? Seems we just need an updated content location.

Started over today and was able to get the IDE to setup correctly. The Hue binding was not included in the OH1 Addons. Is there a reason it did not load? I was wanting to see if I could figure out how to get groups working on it.

I still can’t successfully setup IDE. Is there any manual way to setup IDE?

I am having the same issue, running Windows 7 64bit. Is there really no solution out there yet? Should I not be attempting this using Windows?

Same issue 49960 build errors !. Tried on two different computers … not success.
The errors seem related to missing references , Even ?xml is unrecognized !

I’m late to the party, but I successfully installed Eclipse Smarthome designer on Win10 64bit. The final solution for me was to install the Eclipse Windows 32-bit Release package (don’t install 64-bit version!) from here: https://github.com/eclipse/smarthome/blob/master/docs/documentation/community/downloads.md

  • Thomas