Unable to start OpenHAB2 after retrying a failed install

This is my first attempt in setting up OpenHAB (or any other smart-home platform).

I pulled the latest binaries, latest stable JDK from ZULU and installing on a HP Stream Mini 200-010 running Windows 10. I didn’t use any ARM binaries which I think is correct.

First attempt, I was able to start the server and see the UI on localhost:8080. However, I must have made a mistake with the config file while attempting the “install as service” steps as the service would not start. So, I tried to go back and start from scratch. What I did:

  1. Deleted the service with SC DELETE OpenHAB2 (confirmed that it deleted the service)
  2. Deleted the OpenHAB2 folder which I extracted the binaries to
  3. Re extracted the binaries from the downloaded archive to the same path
  4. Ran start.bat

I’ve rebooted the machine and tried multiple times. But, when I run start.bat it simply opens a new console window but doesn’t run anything. What can I do to fix this?

On a side note: I had UltraVNC server running on this machine as well. After OpenHAB installation, I’m unable to connect via VNC as well. I’m not sure an OpenHAB component caused it (or may be the new JDK did?). Is there any known conflicts with VNC software?

Make sure you did perform all the steps in


Those were the steps I was following.

Is there’s a log at least that I could look at to see an error message?

If you read down further that page you will find:


1 Like