Unable to upgrade from 3.1.1 to 3.2

Hi,

I tried to upgrade to 3.2 but neither openhabian-config nor apt get-update and apt-get upgrade show me that there’s a new version available.

If I try to upgrade to 3.2 through the openhabian config menu, the tool tells me that openhabian 3 is already installed and migration will be canceled.

Any ideas?

  • what is the output of dpkg -l openhab
  • what is the content of /etc/apt/sources.list.d/openhab.list ( name could differ in your installation )
  • is there any error message when you do sudo apt-get update ?

dpkg -l openhab:

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  openhab        3.1.1-1      all          openhab

openhab.list does not exist, nor any other version of the file, which is strange. I’ve recreated the file with

echo 'deb https://openhab.jfrog.io/artifactory/openhab-linuxpkg stable main' | sudo tee /etc/apt/sources.list.d/openhab.list

apt-get update does not show any errors.

I updated to 3.1.1 a week ago with apt get and apt upgrade, so I don’t know how the list file could disappear?

could be that the name on your system is different. Just check the content of other files.
With sudo apt-get -s upgrade you can check what would be updated when you would run the same command but without the -s ( simulate ) switch.
In case you just added the openhab repo you need to run apt-get update before but I assume that you have done that already.

I have the same issue:

A few month ago I installed OpenHABian with OpenHAB 3.1.0 on a new fresh Raspberry PI 4B.

Today I followed the update instructions on the release notes for 3.2.0 which says, you have to select menu entry “03 - Install OpenHAB”. After that I got the message, that openhab 3 is already installed…

sudo apt-get update ends with no errors.

Output of dpkg -l openhab:

openhab | 3.1.0 | all | openhab

That just updates syncs the repository ‘database’ to a local file - which is necessary to be done before doing the real work.
To do the update you need to run
sudo apt-get upgrade

In case you don’t want to do that for you whole system at the related package to be updated a the end of the command.

Thanks, that worked, no OpenHAB 3.2 is installed due to the sudo apt-get upgrade command. So the upgrade instrcutions in the Release Notes are wrong.

@Wolfang, I have a similar issue, unable to upgrade to 3.2.
I tried both with configure-openhab and with apt upgrade, but there is an error I am not able to manage.
I’d appreciate help.
Below the log

login as: xxxx

      |_|                  openHAB 3.1.0 - Release Build

bruno@openhabian:~ $ sudo openhabian-config
 ...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc-bin : Depends: libvlc-bin (= 3.0.12-0+deb10u1+rpt2+arm64) but 3.0.12-0+deb10u1+rpt3 is to be installed
 vlc-plugin-skins2 : Depends: vlc-plugin-qt (= 3.0.12-0+deb10u1+rpt3) but 3.0.12-0+deb10u1+rpt2+arm64 is to be installed
E: Broken packages
+ echo FAILED
FAILED
+ return 1
+ '[' 1 -ne 0 ']'
+ whiptail --msgbox 'There was an error or interruption during the execution of:\n  "02 | Upgrade System"\n\nPlease try again. If the error persists, please read /opt/openhabian/docs/openhabian-DEBUG.md or https://github.com/openhab/openhabian/blob/main/docs/openhabian-DEBUG.md how to proceed.' 14 80
+ return 0
+ true
 ...
 
bruno@openhabian:~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc-bin : Depends: libvlc-bin (= 3.0.12-0+deb10u1+rpt2+arm64) but 3.0.12-0+deb10u1+rpt3 is to be installed
 vlc-plugin-skins2 : Depends: vlc-plugin-qt (= 3.0.12-0+deb10u1+rpt3) but 3.0.12-0+deb10u1+rpt2+arm64 is to be installed
E: Broken packages

bruno@openhabian:~ $ dpkg -l openhab
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  openhab        3.1.0-1      all          openhab

CONTENT of /etc/apt/sources.list.d/openhab.list

deb JFrog stable main

Thanks

Did you try either to just upgrade openhab:
sudo apt-get upgrade openhab
resp. in case you also have the addons installed:
sudo apt-get upgrade openhab openhab-addons

Other possibility might be to first deinstall the packages with the unmet dependencies ( vlc-bin, vlc-plugin-skin2 ) and thendothe upgrade.

Ok, solved after removing the two packages.
Many thanks for your quick help :smiley:

1 Like