Unifi connected, but thing won't update

Hi community !

I have an issue with the Unifi binding.
It seem to connect to my Unifi server because if I enter wrong password in the Unifi Controller thing,
I got error message.

The problem is UniFi thing won’t update, all channel stay NULL.
Everything are installed on the same server, Ubuntu 16.04
The Unifi server are 6.5.55
OpenHab are 3.1.0 installed with docker

I have try to enable DEBUG logging, but doesn’t seem to work
(Ubiquiti Unifi Binding Feature Discussion - #853 by porthos)

nano -w /opt/openhab/userdata/etc/org.ops4j.pax.logging.cfg
log4j2.logger.unifi.name = org.openhab.binding.unifi
log4j2.logger.unifi.level = DEBUG

Before, I had Unifi 6.2 and Openhab 2.x installed an everything worked.
Since the upgrade (I did a new, clean install) nothing work.

Did you have some idea about the problem ?

Thank you !

There have been some changes since 3.1.0. So you might want to update openHAB to 3.2.0. Using the market place you could try the beta version of market place unifi binding. But I’m not sure if it works for 3.1.0, as I didn’t try it with 3.1.0.

Logging file changed a bit in openHAB 3. See Logging | openHAB it explains why you don’t see any logging.

Thank you, you solved my problem !

In fact, I was using information for OpenHab 2.x
With the link you gave me, I have modified the file /opt/openhab/userdata/etc/log4j2.xml and added this

<Logger level="DEBUG" name="org.openhab.binding.unifi" />

As soon I saved the file, I got the error in the openhab log file

2022-02-13 10:19:43.583 [DEBUG] [i.internal.api.model.UniFiController] - Could not find a matching client for id = aafa4c7b9ebe

In older version, MAC address without “:” worked.
So I just added “:” in the MAC address and everything work !