Unifi OH 3.4 not working any more


I upgraded to OH 3.4 stable and unifi stopped working:

2022-12-19 15:34:18.837 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'unifi:controller:home' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): Unknown HTTP status code 404 returned by the controller

Thing configuration is unchanged:

Bridge unifi:controller:home "UniFi Controller" [ host="", port=443, unifios=true, username="xxx", password="yyy", refresh=60 ] {

Further logs I could map to the unifi binding:

2022-12-19 16:32:18.282 [WARN ] [ty.util.ssl.SslContextFactory.config] - Trusting all certificates configured for Client@3ce69d[provider=null,keyStore=null,trustStore=null]
2022-12-19 16:32:18.283 [WARN ] [ty.util.ssl.SslContextFactory.config] - No Client EndPointIdentificationAlgorithm configured for Client@3ce69d[provider=null,keyStore=null,trustStore=null]
==> /var/log/openhab/events.log <==
2022-12-19 16:32:18.346 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'unifi:controller:home' changed from UNINITIALIZED to INITIALIZING
2022-12-19 16:32:18.383 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'unifi:controller:home' changed from INITIALIZING to UNKNOWN
2022-12-19 16:32:19.997 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'unifi:controller:home' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR)

I use UniFi OS UDM Pro 1.12.33 and Network 7.2.95.

Any idea?

From what openHAB version did you upgrade?

I upgraded from OH 3.3, I also cleaned the cache already and had several reboots.

The binding didn’t change in this part since 3.3. So not sure why it doesn’t work. Just to chacke can you try the marketplace version of the binding? And/or run some trace log to see if this gives more insight into why it isn’t working.


market place version is beta, correct?
When doing so, I get

2022-12-19 19:35:19.020 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'unifi:controller:home' changed from UNKNOWN to OFFLINE (CONFIGURATION_ERROR): Error establishing an SSL connection with the UniFi controller.

How can I help analyzing? I would call me an advanced user but not a developer.

You can enable logging for the binding in the openHAB console. Use log:set TRACE org.openhab.binding.unifi or set the log level to DEBUG for some less logging. With DEFAULT you can set the log level back to normal. The logging might give some more information and information about what calls the binding makes to UniFi.

I put it back to log:set INFO org.openhab.binding.unifi. I assume this is the standard logging level?

Is it working now?

I just set up a virtual server and installed the new version of openhab onto it and then restored my full openhab backup onto it.

Everything worked including the unifi, fronius, mail, astro bindings.

No, still not working - same issue!
I sent a log incl. traces to Hilbrand as it contains network details I do not want to have public.

I stopped openhab and then ran openhab-cli clean-cache command and then restarted openhab.

I cleaned cache already twice + several reboots, no change.

With new version from 21.12.2022 as beta from market place it now works.
Thanks @hilbrand for fixing!

1 Like