Unknown device - Spirit Z-Wave Plus


I have thermostat Spirit Z-Wave Plus. Device is found - but listed as unknown.
It is inside official z-wave database:

This is OpenHUAB details.

I’m using Aeotec Z-Stick GEN5

I just installed OpenHAB today:) So don’t know much - let me know what other data I can send to help debug problem.

this is part of log file where I think sth goes wrong:

2017-12-12 23:05:00.378 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 2: setupNetworkKey useSchemeZero=false
2017-12-12 23:05:00.379 [WARN ] [tocol.commandclass.ZWaveCommandClass] - NODE 2: Unsupported command class COMMAND_CLASS_SECURITY_2
2017-12-12 23:05:00.379 [WARN ] [tocol.commandclass.ZWaveCommandClass] - NODE 2: Unsupported command class COMMAND_CLASS_TRANSPORT_SERVICE
2017-12-12 23:05:00.380 [WARN ] [tocol.commandclass.ZWaveCommandClass] - NODE 2: Unsupported command class COMMAND_CLASS_SUPERVISION
2017-12-12 23:05:00.493 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery could not resolve to a thingType! 0148:0003:0001::0.15
2017-12-12 23:05:00.495 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:f90eb581:node2' to inbox.
2017-12-12 23:05:01.683 [WARN ] [lass.ZWaveThermostatModeCommandClass] - NODE 2: Unknown mode type 15
2017-12-12 23:05:02.776 [WARN ] [.ZWaveThermostatSetpointCommandClass] - Reached max tries to init the setpont Furnace, this will be our last attempt 
2017-12-12 23:05:55.556 [WARN ] [ome.core.thing.internal.ThingManager] - Initializing handler for thing 'zwave:device:f90eb581:node2' takes more than 5000ms.
2017-12-12 23:06:13.066 [WARN ] [ome.core.thing.internal.ThingManager] - Initializing handler for thing 'zwave:device:f90eb581:node3' takes more than 5000ms.
2017-12-12 23:06:30.975 [WARN ] [ome.core.thing.internal.ThingManager] - Initializing handler for thing 'zwave:device:f90eb581:node4' takes more than 5000ms.
2017-12-12 23:06:48.231 [ERROR] [ome.io.rest.core.thing.ThingResource] - Exception during HTTP PUT request for update config at 'things/zwave:device:f90eb581:node3/config' for thing 'zwave:device:f90eb581:node3': For input string: "org.openhab.binding.zwave.internal.protocol.ZWaveAssociationGroup@9f3da4"

I hope I’m not diverting the thread, but…

I have a very similar if not the same problem with an identical hardware set-up. I had it working just fine a couple of days ago on a previous version of the 2.2.0-SNAPSHOT release, but I was troubleshooting issues with connectivity and excluded+reset the thermostat and included it back onto the network and now my device isn’t being recognised, showing: “Z-Wave Node 35 (0148:0003:0001:0.15)”

I’ve updated my install a couple of times between having it working and now failing to recognise and I don’t think I have the details of the working version to hand unfortunately, but I do have a backup of my node.xml file showing it successfully added.

Which version did you install? If it’s not the snapshot version, then it won’t be included.

The device is still in the database (I just checked the actual source on GH), so I’m not sure why it wouldn’t work with the latest version.

Thanks for quick response.

I’ve installed 2.1.0, the one from official download page.

Will try to install “snapshot” one …

Hi, I installed nightly build 2.2.0 (build #1133), but no improvement.
Z-Wave addon also 2.2.0
Devices are listed as unknown :frowning:

What else can I do?

Hi all,

I have same problem.

Installed version:
openhab2_2.2.0~20171213031432-1_all.deb …
openhab2-addons_2.2.0~20171213031432-1_all.deb …

thx for help

I can fully confirm that since some last releases devices are unknown.
Have the lattest release.

Please provide more information on the device. What exactly is shown in OH? How is the device identified? What properties are displayed? What version of the software are you using (the “latest” doesn’t really mean so much I’m afraid).

If I look in the binding source on GH, it is included, and has been for quite some time, so clearly we need to find out why it’s not working.

@chris - I’m using “nightly build” #1133 - does it not determine OH version?

This is what is displayed in portal:

z-wave plugin:

Let me know what files, logs to check and I will post information.


Yes - my reply was to another message (just the last one I saw) - not yours.

There was a problem with the database in a recent version, so I’d suggest to update to the absolute latest tomorrow (once all the builds are done) and see if that fixes the problem. The device IDs for your device are in the database.

If that doesn’t help, then I’ll need to see a debug log during the binding initialisation where it checks all the device types to try and work out what’s going on.

Will do, thanks for being active on this!

It would be good to resolve this this week if possible so it’s sorted for 2.2. Unfortunately I’ve not got a lot of time as I’m on holiday right now, but I’ll try and help as I get a few minutes :slight_smile: .


I just installed nightly #1137 and boom :slight_smile:

Thanks for your work - now need to learn how to use it :slight_smile:

1 Like

Same for me: I pulled the most recent build of the zwave binding jar and now it works like a charm, just as well considering I just bought 4 more of these a few days ago - thanks a lot!

1 Like

@addeej - little off-topic - but do you find temperature reading from Spirit responsive?

I had 21.5 C reading in my room - opened window (outside temp is ~5 C) - but after 30 minutes Spirit gives me still temp 21.2 C - where I physically feel much, much colder temp.

I’m quite sure it’s not related to my heater begging still worm.

Hi all.

Its diference betwen:
https://openhab.jfrog.io/openhab/openhab-linuxpkg unstable main

I use a snapshot apt-get Snapshot Release.
I installed this version ower apt-get update/upgrade
openhab2 (2.2.0~20171215110214-1)
openhab2-addons (2.2.0~20171215110214-1)

I stell see as Unknow Device


@pankleks - they seem OK to me, I’ve not had them that long but I have a few in different rooms with multiple temperature sensors and whenever I’ve checked they seem to keep within about 1 degree C or less from the others.

I ran in to the same problem on 2.5.4. Was solved by installing the latest build (2.5.12) of the z-wave binding.