Unknown door sensor

Hi there. I have just reinstalled OpenHab 2 after a break from it. Previously, I was able to discover a Zwave door sensor, now however, it is simply showing up as “unknown device”.

I am not sure how to go about adding devices to the database, but would appreciate some help.

I also have a Zwave lock, which has always shown as unknown. Would love to know if it is possible to get this working.


Is it a battery powered sensor? If so, you need to wake the sensor up several times to give the binding a change to interrogate the device to discover what it is. Until it does it will show up as unknown.

If it was discovered in the past it is still in the database.

There is an experimental branch of the 1.9 binding that supports the Security Command class that some have had success using. However, support for it and therefore locks is not yet part of either the 2.0 or 1.9 SNAPSHOT releases.


I’ve left the door sensor for about 24 hours now and still not showing up. I will try disconnecting it and repairing with the zwave sesor.

As for the lock, is it basically just a matter of time before this is a part of openhab 2?


I’ve had this issue recently too.

I have two identical Aeon Labs recessed door sensors. One showed up with the correct information within an hour or so. The other has not been able to be identified for the last week or so, despite a few dozen wake ups by now.

I haven’t tried removing the sensor and adding it again. Let me know if that works.

Interesting, because I’m also used with Aeon Labs sensor.

I also just realised that it ran out of battery yesterday, despite showing as “online” when I tried to pair it, so it could have been operating under poor power conditions. Will have to hunt around for a 1/2AA and get back to you when I can try it again.