Unresolved requirement: Require-Capability: osgi.extender

I updated my openhab setup to 3.4.4 (running on rasperrypi / debian) and now am getting the following error on one of my bindings. This is a binding i have in my addons folder and was built locally. This was working well in 3.4.2. Any help would be appreciated as I’ve been trying to find solution for many hours to no avail.

Thanks.

2023-06-12 17:26:20.724 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/opt/openhab3/addons/org.openhab.binding.pentair-4.0.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.pentair [297]
Unresolved requirement: Require-Capability: osgi.extender; filter:=“(&(osgi.extender=osgi.component)(version>=1.5.0)(!(version>=2.0.0)))”

    at org.eclipse.osgi.container.Module.start(Module.java:463) ~[org.eclipse.osgi-3.17.200.jar:?]
    at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:445) ~[org.eclipse.osgi-3.17.200.jar:?]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [bundleFile:3.7.4]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [bundleFile:3.7.4]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:520) [bundleFile:3.7.4]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [bundleFile:3.7.4]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [bundleFile:3.7.4]

You probably need a updated version of addon cause it expects certain runtime component in specific version which can not be found (osgi.component >= 1.5 && <= 2.0). I suppose OH 4.0 with updated runtime dependencies do not satisfy this requirement any more.

Thanks - I did checkout the 3.4.x branch and compiled the binding in that environment. It looks like that worked.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.