Update from 3.1.0 to 4.1.1, can't log-in from Android tablet

Hello, I’ve been using OpenHAB on Raspberry PIs for years and have just done my bi-annual code update which has taken me from version 3.1.0 to 4.1.1.

I have a simple MQTT system controlled via HABPanel and installation was via the latest image and using OpenHABian (via a Windows 11 PC, Putty, Firefox and WinSCP) to install mosquitto, restore from backup and the system works fine.

However, I can’t get openHAB to work on my Samsung Android (version 14) tablet, on my local network, as to do so I have to log-in to OpenHAB from the Overview page and this fails. On the same tablet it also doesn’t work with Chrome but does work with Firefox. The same results occurred with a Samsung phone.

There is an authentication error in openHAB.log:

[WARN ] [uth.internal.AbstractAuthPageServlet] - Authentication failed from CSRF check failed

Any help apppreciated please.

Clear the cache and cookies in the Chrome browser on the tablet.

Thank you for your reply.

Have cleared all cache and cookies on both Chrome and Samsung internet browsers and no difference, still get the same error message on the openhab log.

See javascript - what is CSRF check failed when going on a website which doesn't require login? - Stack Overflow for a concise description of what a CSRF check error means. For some reason, OH thinks that you are authenticating and then using that authentication token from a different machine.

I don’t know if that helps diagnose the problem any but that’s the meaning of the error.