Update openhabian 2.1 failiing


I’ve just tried an update from 2.0 to 2.1 in openhabian following the instructions on the release in github.

It seems to go through most of it without an issue but then towards the end I got this:

Get:36 https://dl.bintray.com stable/main Translation-en_US
Ign https://dl.bintray.com stable/main Translation-en_US
Get:37 https://dl.bintray.com stable/main Translation-en
Ign https://dl.bintray.com stable/main Translation-en
Get:38 https://dl.bintray.com stable/main Translation-en_US.UTF-8
Ign https://dl.bintray.com stable/main Translation-en_US.UTF-8
Fetched 9,666 kB in 36s (268 kB/s)
W: Failed to fetch http://repo.mosquitto.org/debian/dists/jessie/main/binary-armhf/Packages  Hash Sum mismatch

W: Failed to fetch http://archive.raspberrypi.org/debian/dists/jessie/main/binary-armhf/Packages  Hash Sum mismatch

W: Failed to fetch http://archive.raspberrypi.org/debian/dists/jessie/ui/binary-armhf/Packages  Hash Sum mismatch

W: Failed to fetch https://dl.bintray.com/openhab/apt-repo2/dists/stable/main/binary-armhf/Packages  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

$ apt -y install openhab2=2.1.0-1
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Version '2.1.0-1' for 'openhab2' was not found
FAILED (apt)
[11:13:54] openhabian@openHABianPi:~$

Any ideas if this is a bug in the updater or something I can resolve?

Many thanks


I ran update system instead of just update, then I was able to switch to version 2.1 and it installed correctly.