Update to 2.2 caused MQTT and logging issues. Got it solved

Upgrade to OpenHab 2.2.0-1 had some weird effects. Fortunately it seems i got it solved
Though initially everything seemed OK, I noticed the MQTT commands were not send (I practically only have MQTT commands).
Checked with mqtt-spy if the broker was OK, it was, checked mqtt.cfg, was ok. Nevertheless I reinstalled the broker and the binding, at no prevail.
Ofcourse I started/restarted etc, no effect.
Then I noticed it wasnt just MQTT, also my commands to Raspberry GPIO pins didnt work
However, that I solved by clearing the cache and tmp files.

Checked the log files… weird both the openhab and event logfiles seemed to have stopped totally some time after I did the upgrade. That is described here as well, Logging stopped working and that solved my logging issue.
OK one issue solved
So now I can see that when I hit say a switch, the item state actually does change… but the MQTT command does not go out (doesnt show up in mqtt-spy and had no effect on my peripherals). Also MQTT updates are not received.

Ofcourse I saw Openhab stopped working after update
So I tried that eventhough I understood that issue to be solved and it wasnt really that my OH stopped working: did not help

My Openhab is still getting info from outside (like weather and Astro) and I now can control my GPIO pins again after clearing the cache, so maybe it is only MQTT related

In spite of me having reinstalled the MQTT binding before to try and solve it, I decided to do that again and now also reinstall the MQTT action.
Not sure which of the two did the trick, but that seemed to have solved the issue.

EDIT In the mean time I encountered some other people who were helped by this.
MQTT problems not fixed after reinstalling the binding but only after reinstalling binding AND action

I’ve seen one other report that uninstalling and reinstalling the MQTT binding fixed this for a user who upgraded to 2.2.0-1 also.

I wonder if it the Action is causing problems again or if that problem never got fixed.

1 Like

I also have encountered MQTT problems. I can receive item-updates via the MQTT-Eventbus Topic logic.
But not via normal incoming item-updates. Item-updates go out nonetheless…
uninstalling - reinstalling MQTT-binding didn’t change anything.


Same problem… can’t receive through item binding nor send any update by item binding with mqtt.

Thanks Rich, initially reinstalling just de binding didnt fix it, only when at one time i also did the action it did. Was that the real problem? Don’t know. Maybe it was the many restarts, cleaning cache etc… But yes I saw other people have problems and then reinstalling indeed did the trick.
I was at the point of doing a complete re-install, but I am happy i stuck with it. Once my logfiles were back up at least I had some idea

that indeed sounds like what I experienced. Do you have the action installed?

I do not dare saying where your problem would be Thomas. As said, initially re-installing the binding didnt work for me, only after i did some other tweaking as described… but uit took me almost half a day

Started working… after some time… :wink: Christmas miracle …

1 Like

Great :slight_smile:

Just came upon at least 2 other peole who had their 2.2 upgrade MQTT problems fixed only after reinstall of the MQTT binding and MQTT action


I don’t have MQTT action installed at all (and never had). Just the binding… :thinking:
I deinstalled and reinstalled the binding without a change. I can send item-updates, but not receive them.

Chiming in on this issue. MQTT items not getting updated anymore. Uninstall and reinstall of MQTT binding did not fix it. Is there a way to downgrade the OH version again?

Also I´m getting kicked off from Karaf console after log:tailing for a while. Not a real error message, but someting about SSH

Ok it was SOLVED by uninstalling and stopping Openhab2, then install again :wink:

you mean, it solved the Karaf log:tailing issue or the mqtt also?
I just did an extra install of mqtt-action, reinstalled both and still no incoming update possible…

I have not waited long enough for Karaf to kick me out again :wink: I´ll observe it.
But what I did was … uninstall MQTT binding from Bindings and Actions via PaperUI. Then stopped the openhab2 service. Restarted it, went back into PaperUi and installed them both again. That fixed it.

1 Like

ok. thanks. i tried that one already (without PaperUI, because I’m using config files)… But now I reinstalled OH2 from scratch and now it works!

1 Like