Updating from v2 to v3 - Hue Emulation -

Hi,

I am working on the update from OH2 to OH3 for some weeks. The inplace upgrade was not successful so this is the reason that I copy my whole setup to another machine and work on it in parallel.

I am nearly at the end and now I noticed that the installation of the Hue Emulation addon results in a non working OH3 environment. After installation the UI is not usable anymore. I have to uninstall the binding via Karaf to make it working again.

I have updated to the newest v3.4.1 but still the same issue. I tried to install this binding manually while adding the .jar file to the addons folder but also no success.

In my OH2 environment there is no issue with this. But on OH3 after installation I have the following entry in my OH3 log:

No subresource locator found for path /

Any hints what I can do to solve this issue?

The error message is mentioned in [hueemulation] kills rest api and basic ui on M4 and SNAPSHOT · Issue #10656 · openhab/openhab-addons · GitHub .
According to the tracker it is solved.

  • did you clean the cache ?
  • in case you use .things files check if they are compatible with 3.4.1 syntax

Yes I already saw this case but this did not solve it for me!

I have completely configured every device via UI so there is no manual .things file!

Which cache should I clean? So clean cache, run OH and then install the binding again?

What version of java are you using?

I have started with 3.4.0 stable with the complete new installation/setup.

After noticing the first issues with this binding I have uninstalled it via karaf. Then I updated to the last 3.4.1 but without success.

Maybe the new 4.0.0 snapshot can fix?!

It works fine for me using OH version 3.4.0.

What OS and Java version are you using?

I am running OH on a Windows 10 machine where Zulu Java 11.58.23 is installed!

I did some more investigation. After clearing the cache nothing changed.

If I run OH on my Windows via the “start.bat” file everything is fine and controllable and also the Hue Emulation is running without issues.
If I went back to my default mode that I use the Windows service to start OH, then I am running in this issue. This is reproducable.

I have already deleted and installed the service again without success. Any ideas whats the different is between this 2 start modes via batch and via windows service?

Hmm it looks that there is a general issue. I have downloaded a complete new OH 3.4.1 for Windows and run it. My old version was copied to another destination.

After the initial setup with the username and the location I just installed the Hue emulation binding via UI with the same result. There is no other configuration inside.
The only thing is that this version was started as service and not via batch.

Any hints?

There is an issue report at gihtub [hue] Upgrade to 3.4.1 "breaks" hue-bridge · Issue #14218 · openhab/openhab-addons · GitHub but on first view that looks different compared to your report.

Hue bridge works as designed without issues.

I have installed a complete new windows vm device where only Java and OH 3.4.1 was installed. After the first 3 setup screens I have the same issue with the hue emulation addon.

Seems there is a global/general issue if you use OH as a windows service!

Is there any hint in the windows event log ?

Maybe adding this to openHAB-wrapper.conf will help:

wrapper.java.additional.19=-Dorg.apache.cxf.osgi.http.transport.disable=true

Will try

Thanks

Edit: I don’t know what it is for and what it is doing but it seems to work!! Big thanks.

For now its running and I will finish my v3 implementation now! :slight_smile: