Updating repositories and upgrading installed packages… FAILED

  • Platform information:
    • Hardware: Pi4 4Gb
    • OS: OpenHabian 1.6
    • openHAB version: 2.5.10
  • Issue of the topic:
    Sudo openhabian-config - option 2 (Upgrade system) always results in Updating repositories and upgrading installed packages… FAILED.

Anyone else facing this problem? Or does anyone got any suggestions how to solve this problem?

debug log?

I’ll need some help with that please.
Which log and where can i find it?

This is new for me and i can’t seem to figure it out myself.

:roll_eyes: it’s in the docs

I set debugmode to maximum but /boot/first-boot.log isn’t updated for some reason. last entry is from october 15 in my case.

this is for image installation only. Read carefully.

I see, first-boot.log doesn’t apply to my situation.
Anyway…I can see the extra output in the console after setting debugmode to maximum. But is this output saved to a file?

Jetzt reicht’s mir aber. LIES die Anleitung gefälligst auch.

What a rude answer! And even in German on this English speaking forum. You must be really frustrated about my questions.

FWIW…I spent hours reading last night… the pages you linked, documents and forum postst.
Obviously i couldn’t figure it out myself this time!

I also read this in the post you linked:
Do not hesitate to ask for help on the openHABian community forum ! Remember to mind the rules please.

EDIT: i managed to log the output.
You could have just quoted
"there is no logfile. To record output in this case, you need to configure your terminal client to record and save the command line output. In PuTTy there’s a field called ‘Lines of scrollback’ under the ‘Window’ "

Suggestion to add to the document:
Under logging select “all session output” and select a location where you want to store the logfile under “log file name” .
This way the output is saved to a file.

Sometimes people just need a little bit of help even if the question seems stupid!

Indeed. What you were asking for was right in the first paragraph of the link I gave you.
When then there’s someone to get along to apparently post without reading first (as we expect from from any user) and even not doing it after being told so (and I assume if you had read it you cannot have missed the paragraph, can you ?) then that’s wasting my time which is why it is upsetting me.

I have already spent hours writing the document let alone all the months spent on programming the stuff.

Entschuldige meinen Tonfall. Aber das war einfach einmal zuviel gefragt. Das hätte man nach der Lektüre wissen müssen und das Mindeste wäre eine spezifische Rückfrage gewesen die gezeigt hätte daß du es wenigstens probiert hast. Und du warst an dem Abend nicht der Erste.

I have updated the doc to be hopefully easier to understand and will add your suggestion,too.
Mind though that that needs to work for anybody including those to use different tools and to have a different level of knowledge, so one shares we expect from users to contribute themselvses is to have read the docs and to know how to operate their tools.

The assumption that i haven’t read anything is what is annoying me. I honestly spent hours reading last night.

The following sentence confused me i guess:
“If you do not use the image but use openhabian-config manually”

I am using an image of openhabian so i thought this didn’t apply to me. I did read it but apparently not good enough or maybe it is the lack of knowledge that i don’t know the difference between ‘using the image’ and ‘use openhabian-config manually’. Which i appologize for.

Also i don’t know why you keep speaking german but i get your point. It’s oke. I understand you get these kind of questions all the time.
But please keep i mind that the person you replying to might also have had a bad day, is tired, doesn’t have the knowledge, or simply just misread / overlooked something.

Thanks for updating the docs.

Sorry I assumed you’re German. Aren’t you ?

See…that’s your second wrong assumption. I’m not German

Ok my mistake then. It was an apology for the tone I used but as a non native speaker you cannot fully understand what I wrote.

The point is hard to bring across when we’re both not using our native language that’s why I used German.

I understand that but you in turn need to see that it was almost mandatory to assume you didn’t read the docs because the answer was clearly there, in the very first paragraph of the document I’ve referenced twice.
So I believed that the guy I talked to was just too lazy to read the docs even after I pointed him there and is fine with wasting my time rather than to spend some of his to get stuff going only he wants.
In addition to the time I had already spent to develop and document for him.

And that is something completely different than to ask stupid questions (which by itself is ok). It means that person is brazen and impudent or whatever the appropriate English term for that is, I don’t know for sure.
Ok that wasn’t the case so I apologize.
But what else would you have thought in such case ?
And you were the third one that day. The n+1’th one. The one too much.

If you had asked “I don’t understand the meaning of X” it would have at least shown effort on your side but in absence of any such indication it was reasonable to assume what I did.

I have not seen this error using this exact option. The times I did see it, manually running sudo apt update and if I remember you should run sudo apt upgrade made the problem go away.

I tried debugging once but could not get any errors from the apt/openhabian command. Once I added a debug log in the openhabian commands it worked.

Probably my thoughts would have been the same. But my actions would have been different.
Instead of telling to read carefully twice i would have just quoted the relevant line in the document. Just like i said in my previous post. I would have cost you less of your valuable time.

Anyway, i appologize for coming accross as lazy and i’ll try to be more specific in future questions

Again, i appreciate the work and effort you put into documenting and developping very much!

manually running sudo apt update & apt ugrade works fine indeed.
For now the error is not showing up when using option 2 in openhabian-config.
But there are also no apt updates available at the moment for me.
So let’s wait and see what happens when there is something to update.