Upgrade 2.4 to 2.5 openHAB Cloud and Zwave

My system is on a RasPi 3B raspibian openHAB install with apt-get , been running 2.4 stable for a year or so, upgraded to 2.5 last night. Very high CPU usage and my zwave controller keeps restarting.

I’ve been fighting this all day. Finally figured out I can’t have zwave and openHAB Cloud Connector running at the same time.

I have cleaned cache and re-booted multiple times.

The category of some bindings, restdocs for example, has been changed from misc- to ui-:

Continuing the discussion from Upgrade 2.4 to 2.5 openHAB Cloud and Zwave:

Yes, I saw this thread, but I still can’t run openHAB cloud with zwave.

I have this combination running without any issues.
Check your addons.cfg for invalid entries (version1 bindings where version2 bindings exist, but you still have the system setting for legacy bindings set to OFF).
Also check the release notes for 2.5 stable.

1 Like

@asjohnson9 also check /var/lib/openhab2/config/org/openhab/addons.config for invalid entries as well as addons.cfg as sihui mentioned. If you need to make a change to /var/lib/openhab2/config/org/openhab/addons.config stop OH first then make the change.

Another idea is to maybe try uninstalling the cloud binding, deleting the UUID in var/lib/openhab2/uuid (use text editor and not just delete the file) and reinstall the binding. A new uuid will be created and you can then go to myopencloud site and remove the old uuid and replace with the new one.

1 Like

I re-installed the cloud binding this morning. All was well. This afternoon, I realized that I had un-installed the amazonechocontrol binding as part of my troubleshooting. As soon as I attempted to install the amazon binding, my zwave controller stopped.

Essentially, when I make changes, my zwave controller stops. I attempted to manually start from the console, it is currently in “Waiting” mode.

Not sure what is happening but maybe try installing the Amazon binding via jar file from either here:

or the beta version at the top of page here:

Place the jar file in usr/share/openhab2/addons then restart OH.

As mentioned, I’m not certain that this will fix your problem but it’s worth a shot.

A copy of a startup log (openhab.log) uploaded here might provide some clues for getting to the bottom of your problem rather than guessing at exactly what’s going on based solely on the symptoms. I also think it might not hurt to see what bindings are installed and active. A common problem is having multiple versions of the same binding installed simultaneously:

ssh -p 8101 openhab@localhost
bundle:list -s -r | grep ' (Active|Resolved) '

[Edited to show both Active and Resolved bundles when listing bundles in the karaf console.]

1 Like

@scottk Good point Scott, I had assumed (yep I know what that just made me.:rofl:) checking the addons.cfg and addons.config would show if a duplicate existed.

After giving it a bit more thought you are correct…a single listing in config does not mean Karaf has only one version installed and active.

The logs were not telling me a lot, just “Zwave stopped”. I got things working yesterday by using the amazonechocontro.jar file and removing/reinstalling the zwave binding from paper UI. Kind of strange, I was running the 2.5 zwave beta on my 2.4 version prior to this weekend.

Glad you got it working, guess my suggestion worked.:grinning:

I would still do as @scottk mentioned and check if there are duplicated listed in the console.

Please click the square box on the post with solution to mark as solved.

1 Like

That is interesting, I run both of them in my own installation without any problem. Maybe a problem with your environment, to less memory or something like this?