Upgrade 3.4 -> 4.0.2: Java 17 and still Error installing boot features

Dear openhabians,

after updating from my openhab 3.4 installation to 4.0.2 (i upgraded to java 17 beforehand via openhabian-config) my openhab started, but with major hiccups (it was stuck in a startup loop).
After a clean-cache and multiple restarts I wasn’t able to fix that behaviour and could not access karaf console to further deactivate bindings to track down the issue.
I then looked around in the openhabian-config tool and I found that it was still on the Openhab3 branch. I changed it to the release setting and then selected upgrade, which did give me that it successfully reconfigured java 17 but didnt install anysthing. I then selected install openhab.
Well, probably my fault but something is broken now. Openhab fails to start with

2023-09-02 08:42:29.380 [ERROR] [ternal.service.BootFeaturesInstaller] - Error installing boot features

java -version tells me I have JDK-17. I have also tried to manually install jdk-17 with no luck.

I’m on a raspberry pi4 4G with bullseye.

Any help would be appreciated!

Thank you so much,


Don’t know if that will help at the end but what is the output of following commands to gather information:

cat /var/lib/openhab/etc/version.properties
uname -a
cat /etc/os-release
java --version

What is shown in the about menu ( 00 ) in openhabian ? First two rows show several version information.

Hi and thanks for your answer,

here is what I was able to gather:

cat /var/lib/openhab/etc/version.properties
openHAB Distribution Version Information
build-no        : Release Build
online-repo     : https://openhab.jfrog.io/openhab/libs-release

Repository        Version
openhab-distro  : 4.0.2
openhab-core    : 4.0.2
openhab-addons  : 4.0.2
karaf           : 4.4.3
 uname -a
Linux openhabplus 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr  3 17:24:16 BST 2023 aarch64 GNU/Linux
cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
NAME="Raspbian GNU/Linux"
VERSION="11 (bullseye)"
java --version
openjdk 17.0.7 2023-04-18
OpenJDK Runtime Environment (build 17.0.7+7-Raspbian-1deb11u1rpt1)
OpenJDK Client VM (build 17.0.7+7-Raspbian-1deb11u1rpt1, mixed mode, emulated-client)

And openhabian-config “about”

openHABian Configuration Tool — [openHAB]{2023-08-17T19:14:50+02:00}(e41f8eb)                                    │ 
│ openHAB 4.0.2 - Release Build                                                                                    │ 
│                                                                                                                  │ 
│ This tool provides a little help to make your openHAB experience as comfortable as possible.                     │ 
│ Make sure you have read the README and know about the Debug and Backup guides in /opt/openhabian/docs.           │ 
│                                                                                                                  │ 
│ Menu 01 will allow you to select the standard ("openHAB") or the very latest ("main") openHABian version.        │ 
│ Menu 02 will upgrade all of your OS and applications to the latest versions, including openHAB.                  │ 
│ Menu 03 will install or upgrade openHAB to the latest version available.                                         │ 
│ Menu 10 provides a number of system tweaks. These are already active after a standard installation.              │ 
│ Menu 20 allows you to install some supported optional components often used with openHAB.                        │ 
│ Menu 30 allows you to change system configuration options to match your hardware.                                │ 
│ Menu 40 allows you to select the standard release, milestone or very latest development version of openHAB.      │ 
│ Menu 50 provides options to backup and restore either your openHAB configuration or the whole system.            │ 
│                                                                                                                  │ 
│ Visit these sites for more information:                                                                          │ 
│   - Documentation: https://www.openhab.org/docs/installation/openhabian.html                                     │ 
│   - Development: https://github.com/openhab/openhabian                                                           │ 
│   - Discussion: https://community.openhab.org/t/13379     

Looks ok to me, or am I missing something`?

Looks like your instances runs in 64-bit mode: aarch64
Did you install the 64-bit image ?

Hi, hmm not intentionally…

But I have gotten it to work again now, and this time even without the hiccups I experienced beforehand. This is what I did (again):
Stop openhab
Clean cache
Select JDK17 in openhabian-config
Select release as current openhab flavor
Select upgrade openhab
Select install openhab

I have tried all those things before, but for some reason it worked now.
Thank you Wolfgang for your help and time!