Upgrade failed from 3.0 to 3.2

Hello, i`m getting an error when i try to upgrade from 3.0 to 3.2 version, something related to “Could not handshake…”.
Does anyone have any idea what could be the problem?

Err:1 https://dl.bintray.com/openhab/apt-repo2 stable/main armhf openhab all 3.0.2-1
  Could not handshake: The TLS connection was non-properly terminated. [IP: 35.157.165.119 443]
Err:2 https://dl.bintray.com/openhab/apt-repo2 stable/main armhf openhab-addons all 3.0.2-1
  Could not handshake: The TLS connection was non-properly terminated. [IP: 35.157.165.119 443]
E: Failed to fetch https://dl.bintray.com/openhab/apt-repo2/pool/main/3.0.2/openhab_3.0.2-1_all.deb  Could not handshake: The TLS connection was non-properly terminated. [IP: 35.157.165.119 443]
E: Failed to fetch https://dl.bintray.com/openhab/apt-repo2/pool/main/3.0.2/openhab-addons_3.0.2-1_all.deb  Could not handshake: The TLS connection was non-properly terminated. [IP: 35.157.165.119 443]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
FAILED

This seems to solve the problem