Upgrade impossible "Download of 3.0.0 failed because it's not a valid version"

Hello,

I’m trying to upgrade my Openhab install since few days following this doc Migration to openHAB 3 | openHAB but it keep failing.

I’m running a standard install on Windows, and currently run the 2.5.5 version.

I’ve tried multiple version numbers just in case, but it always fail with this error message

What is the issue?

(oh and btw, the PowerShell window close itself after displaying it making it a really pain in the bass to even read it)

Thanks a lot.

Edit: For anyone reading this having the same issue: To upgrade from version 3.0.1 or earlier, it wont work due to an outdated url in the update script. Download the lastest version and copy/past the update script from runtime\bin then run it again.
It should not matter to much as, if I’m right, the script first download the latest version, then use the update script form the downloaded version, so it’s just a shortcut :slight_smile:

Did you try: 3.0.2 ?
You can lookup the current stable version at Download openHAB | openHAB

Hello, thanks for the reply!

I indeed try 3.0.2 as version number, and still got the same kind of issue

I have no issue downloading a standalone version from your link, but I dont know how to properly upgrade my current version with this :confused:
I tried to use the conf files as much as possible, but I still have some configurations done with the gui (like installing bindings or other things like that). Can I migrate this differently?

3.0.2 must be correct.
I would assume that between 2.X and 3.X the URLs might have changed and the one you have points to a different location.
Could you have a look to the Powershell script update.ps1 ?
What is the DownLoadLocation in the script ? There are several but is this one of them ?

$DownloadLocation = "https://www.openhab.org/download/releases/org/openhab/distro/openhab/$OHVersionName/openhab-$OHVersionName.zip"

Between your version & 3.0.2 the repos on bintray shut down. The latest 2.5 & 3.0 are on artifactory. Is it possible to upgrade to 2.5.12 first?

You should be able to download it from here. Apparently the 2.5 links were not updated when the URLs changed.

That was my main issue, no update seem to be possible at all :confused: But at first I though that 2.x.x version was not available, not that the download link was broken…

I saw multiple of them but I think the one you’re asking is this one :

$DownloadLocation = "https://bintray.com/openhab/mvn/download_file?file_path=org%2Fopenhab%2Fdistro%2Fopenhab%2F$OHVersion%2Fopenhab-$OHVersion.zip"

So for the science I’ve patch this script like a literal barbarian and ran it again and… it seem to have been able to process the update without any other issue :slight_smile:
I’m not sure everything went fine as I got many error when I run the start.bat now, but at least I have a backup so if there is a better way to process I’m in :slight_smile:

Edit: I’ve rolled back on my 2.5.5 version (people was not super happy here without openhab running properly, seem like we need it more than I though :smiley: ) and try an update to 2.5.12 first to be sure, but it also tell me this version is not a valide one :frowning:

If there is no other solution to upgrade, I’ll try to debug my broken 3.0.2… Or even try a clean install

1 Like

2.5.12 also is available via the download link I shared earlier.
Using the update script the download link will evaluate and redirect to https://openhab.jfrog.io/artifactory/libs-release-local/org/openhab/distro/openhab/2.5.12/openhab-2.5.12.zip.

2 Likes

oh that’s a great idea, I’ll try that!

Edit: Sadly, and strangely, the 2.5.12 version still have the unworking bintray.com in the update conf :confused: Does this mean people downloading the last 2.x.x verison right now will not be able to auto upgrade?
And btw, Snapshot and Milestone does use the new url, could this be a solution ?

Could I upgrade to the latest snapshot then downgrade to the 3.0.2 somehow?

In the mean time, I’ll try once again the 3.0.x update script

Edit of the edit: the same url is used in the 3.0.1 version too :confused: So I got my update script from the 3.0.2 one, seem strange

Edit again: I’ve finally was able to upgrade (look like my first try was already fine, but I forgot to update my java version too… As I was not expecting this url trick to work I though it was something else ^^’)

The move away from bintray was rushed because, if I recall correctly, there was only 30 days notice before the shutdown to set up a new provider, and deploy new software versions…

1 Like

Oh ok, that would explain it indeed. Seem strange that the openhab team was trying to keep backward compatibility for years and studently let down people that was not on the latest build.
But if the fix of using the last update script is fine, at least it’s something.

… and about this, everything seem to work fine with my new 3.0.2 build (I’ll need to learn this new awesome ui tho) and everything seem nice… except the database :confused: I’m not sure if I have missed something but my simple postgresql conf seem to not work anymore (item are not saved on change, with the same conf files \services\jdbc.cfg and \persistence\jdbc.persist)

Could this be an issue from this forced upgrade? (I dont remember seeing anything about breaking changes in this conf)

Edit: The log was telling me that “JDBC::openConnection: no driver available” so I went into the ui, uninstall and reinstall JDBC Persistence PostgreSQL and boom, everything is now fine somehow :confused:

But at least, my upgrade is done and everything work! So thanks a lot for the help!

2 Likes