Upgrade issues

I tried to give me a X-Mas present to ugrade from 2.5 to 3.0 according to the described 3 steps :slight_smile: .
But the installer left me in the rain with :frowning: :

The following packages have unmet dependencies:
 openhab : Conflicts: openhab2 but 2.5.11-1 is to be installed
           Breaks: openhab2 (< 3.0.0~) but 2.5.11-1 is to be installed
 openhab-addons : Conflicts: openhab2 but 2.5.11-1 is to be installed
                  Breaks: openhab2 (< 3.0.0~) but 2.5.11-1 is to be installed
E: Unable to correct problems, you have held broken packages.
FAILED (install openHAB)

Is this a known issue?


It seems this is due to pending changes which were coming in for OH2.5. So I did a normal system upgrade which failed in the end with problems with netfilter/iptables persistent packages. I apt removed those two and reinstalled. Then the 2.5 upgrade went through. Then I kicked the 3.0 upgrade again via Installer. A dialog appeared that the upgrade was successful but after that it showed that there was an error during install and that I should retry. Checking the console shows:

2020-12-25_12:56:47_CET [openHABian] Deleting mapdb persistence files... OK
2020-12-25_12:56:47_CET [openHABian] Migrating Amanda config... OK
2020-12-25_12:56:47_CET [openHABian] Migrating Samba and mount units...
$ systemctl stop smbd nmbd

$ systemctl disable --now srv-openhab2-addons.mount srv-openhab2-conf.mount srv-openhab2-userdata.mount srv-openhab2-sys.mount

$ systemctl enable --now srv-openhab-addons.mount srv-openhab-conf.mount srv-openhab-userdata.mount srv-openhab-sys.mount
Failed to enable unit: Unit file srv-openhab\x2daddons.mount does not exist.
FAILED (reenable mount units)
2020-12-25_12:56:55_CET [openHABian] Checking for default openHABian username:password combination... FAILED
2020-12-25_12:56:57_CET [openHABian] We hope you got what you came for! See you again soon ;)

Googling for that error shows: [OH3] openhabian-config path error in openHAB related (40) --> Upgrade to OH3 (42) · Issue #1272 · openhab/openhabian · GitHub

I applied the steps described there (Apply improvements/Samba) and that went through fine. Share is available.

When I try to make sure I have all the latest things now with update (02) it wants to downgrade java to 8 again and still fails to check the default username/password:

2020-12-25_13:12:39_CET [openHABian] Updating repositories and upgrading installed packages...
$ apt-get upgrade --yes
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  rpi-eeprom-images triggerhappy
Use 'sudo apt autoremove' to remove them.
The following packages have been kept back:
  libnode64 nodejs python-rpi.gpio
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

$ java_install_or_update Zulu8-32

$ java_zulu_update_available Zulu8-32
2020-12-25_13:12:44_CET [openHABian] Installing Java Zulu prerequisites (libc, libstdc++, zlib1g)... OK

$ java -version
openjdk version "11.0.9" 2020-10-20 LTS
OpenJDK Runtime Environment Zulu11.43+88-CA (build 11.0.9+11-LTS)
OpenJDK Client VM Zulu11.43+88-CA (build 11.0.9+11-LTS, mixed mode)
2020-12-25_13:12:50_CET [openHABian] Checking for default openHABian username:password combination... FAILED
2020-12-25_13:12:52_CET [openHABian] We hope you got what you came for! See you again soon ;)


After a restart, MOTD shows still 2.5 and shows an error:

sed: can't read /var/lib/openhab2/etc/version.properties: No such file or directory

Updating the system still tries to install jdk8.

Invoking the UI shows the new style and my items and rules are still there - yay :D!
That nicely auto-generated startpage e.g. with a link to Grafana/Habpanel/Logviewer is gone (I guess by design) but invoking Grafana directy works still trying to find Habpanel and Logviewer though…

Tried /habpanel, but it simply shows
Connection lost! Trying to reconnect...
as it fails to load /app/widgets/clock/clock.widget.js with 404.

Tried :9001 for Logviewer but still seems to point to openhab2 log. Adapted /etc/systemd/system/frontail.service manually.

UPDATE3: seems related to 3.0 release · Issue #1308 · openhab/openhabian · GitHub - being on the wrong branch after the migration. Now switched to openHAB3 seems to fix some of the filesystem path related errors.

moved your post as it was off topic.

what does that mean?
How did you manage to install OH3 without switching to openHAB3 branch ?