Upgrade to 4.2 from 4.1.3-1 - no icons for items in default sitemap BasicUI

Hey, I’ve OH installation running on rPI for many years now (installed from apt), just upgraded as in the subject and can’t see icons for items (neither for defined in the GUI nor in files, still have some of them). In 4.1.3 it was all ok. I restarted the OH (not the server though), I cleaned cache (using sudo openhab-cli clean-cache) but can’t get the icons displayed. There seem to be a setting in the GUI which was set to Disable after the upgrade:

I changed it to Enable but no difference so returned to the Disable value as I don’t want to mess around with it. Any hints?

Ignore my ask please, I did nothing and icons appeared after about 1h from upgrade. Seems it needed time. Subject solved by itself…

Same problem here using chrome browser and basicui - no icons, no charts visible. However, no problems with the android app. Ctrl + F5 did the job. Now it works fine.
Ctrl + F5 forces a reload of the webpage, not using the cached page. This will retrieve a completely new page.